Author Topic: App Store now allows Older App Versions Download!  (Read 13131 times)

Offline BetterFolders

  • Senior Member
  • ***
  • Posts: 93
  • Country: ge
    • View Profile
  • Device: iPhone 2G
  • My Computer: Mac
Re: App Store now allows Older App Versions Download!!!
« Reply #15 on: September 18, 2013, 05:19:06 PM »
Yep on stock. I guess it's wd related

Offline cuek80

  • Senior Member
  • ***
  • Posts: 25
  • Country: id
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPod Touch 2G
  • My Computer: Windows
Re: App Store now allows Older App Versions Download!!!
« Reply #16 on: September 19, 2013, 03:34:24 AM »
Hopefully good news soon :p

Offline mackerm

  • Member
  • **
  • Posts: 18
  • Country: us
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPod Touch 2G
  • My Computer: Mac
Re: App Store now allows Older App Versions Download!!!
« Reply #17 on: September 19, 2013, 06:18:56 AM »
I'm curious to know if this new feature is of ANY use to 3.1.3 users. I tried to download an app called BeyondPrint Reader which was recently upgraded from requiring iOS 3.0 to requiring iOS 5.0. It wouldn't let me download the old version.

This article on Low End Mac talks about problems for iOS 3, but I don't know if he's just referring to glitches in the iTunes store on a 1st gen. iPod, or if it won't let you download "last version" iOS 3.1.3 apps at all.
« Last Edit: September 19, 2013, 06:27:12 AM by mackerm »

Offline PierreP

  • WD FAQ Maker
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 2027
  • Country: cr
  • Everything is Relative
    • View Profile
  • Device: iPhone 3G
  • My Computer: Windows
Re: App Store now allows Older App Versions Download!
« Reply #18 on: September 19, 2013, 04:50:08 PM »
...App Store now allows to download older versions...

It's about time that Apple/iTunes enable this after millions upon millions of frustrated users & complaints all over the web about not being able to download older versions of apps compatible with their older iOS.

Still missing in iTunes: a simple drop down menu to filter searches by iOS compatibility.

See workaround using Google here, a proof that if a simple user can do it on his computer then it should be a piece of cake for the brilliant iTunes' engineers to implement: [Tutorial] Whited00r 6 How-To Find iOS 3.1.3 iOS 4.1 & 4.2.1 Compatible Apps - iTunes Filter 3.x

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
Re: App Store now allows Older App Versions Download!
« Reply #19 on: September 19, 2013, 05:23:04 PM »
It's about time that Apple/iTunes enable this after millions upon millions of frustrated users & complaints all over the web about not being able to download older versions of apps compatible with their older iOS.

Still missing in iTunes: a simple drop down menu to filter searches by iOS compatibility.

See workaround using Google here, a proof that if a simple user can do it on his computer then it should be a piece of cake for the brilliant iTunes' engineers to implement: [Tutorial] Whited00r 6 How-To Find iOS 3.1.3 iOS 4.1 & 4.2.1 Compatible Apps - iTunes Filter 3.x


It is still imperfect though, one by the drop down menu you suggested, or even in the page for the apps telling what the lowest iOS version it supported was.

That, and letting people leave reviews, even if they are using older versions of apps.  That is a terrible thing, because people often won't realize that they are not using the latest version, and can't use it, and the developer can't update it for them, ever.  So, they leave bad reviews, based on their experience, which the developer can't help. :(

Offline Fireshibby

  • Member
  • **
  • Posts: 20
  • Country: us
  • iOS/Apple Enthusiest, And Technology Lover
    • View Profile
    • Nate's Blog
  • Device: iPhone 2G
  • My Computer: Mac
Re: App Store now allows Older App Versions Download!
« Reply #20 on: September 19, 2013, 05:40:48 PM »
I realized like 5 minutes after I posted my thread that this one existed lol. I'm currently restoring back to stock 3.1.3, and I'm gonna see if it works as well and I'll report back my success/failure!

*Edit*
Well it looks like it isn't working on stock 3.1.3. I've tried Facebook, Twitter, and Instagram. I'll still browse around the Appstore and see if there's anything at all that would download
« Last Edit: September 19, 2013, 05:52:08 PM by Fireshibby »
~Fireshibby

Offline Eric

  • Hero Member
  • ****
  • Posts: 245
  • Country: 00
  • Redd00r Helper and Archetype User
    • View Profile
  • Device: iPod Touch 2G
  • My Computer: Mac
Re: App Store now allows Older App Versions Download!
« Reply #21 on: September 19, 2013, 09:23:19 PM »
IPod touch 2G owners would be happy if redd00r was working.
- iPod touch 2G Mc
- iPad 2 wifi
- HTC One M8

Offline benefactor

  • Junior Member
  • *
  • Posts: 7
  • Country: gb
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPhone 3G
  • My Computer: Windows
Re: App Store now allows Older App Versions Download!
« Reply #22 on: September 20, 2013, 08:29:27 AM »
it works with 3g but you have to update it to 4.2.1 first  :-\

Offline woc

  • Member
  • **
  • Posts: 19
  • Country: it
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPhone 3G
  • My Computer: Mac
Re: App Store now allows Older App Versions Download!
« Reply #23 on: September 20, 2013, 08:48:59 AM »
To the WD6 developers:
- Could you have a try to run AppStore app taken from 4.2.1 on WD6 3.1.3? AppStore in the end is a simple app. Maybe it doesn't use new apis introduced in iOs4 and maybe the linked symbols in the 3.1.3 could be enough.

Offline leejenshil

  • Hero Member
  • ****
  • Posts: 180
  • Country: il
  • graphical disianer
    • View Profile
  • Device: iPhone 2G
  • My Computer: Windows
Re: App Store now allows Older App Versions Download!
« Reply #24 on: September 20, 2013, 11:13:27 AM »
To the WD6 developers:
- Could you have a try to run AppStore app taken from 4.2.1 on WD6 3.1.3? AppStore in the end is a simple app. Maybe it doesn't use new apis introduced in iOs4 and maybe the linked symbols in the 3.1.3 could be enough.

what you just said does not make any sense, if they would want this to work they would delete the "appmarket" icon and just make a icon for the ATM, put the stock cydia ( just the icon on springboard ) and leave the appstore the way it is on stock ios 3.1.3 ( there is no need for the backup icon because it does not work any more  :( )
way would you port the ios 4 one? that would just take time for the same result you would get from this.

Offline woc

  • Member
  • **
  • Posts: 19
  • Country: it
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPhone 3G
  • My Computer: Mac
Re: App Store now allows Older App Versions Download!
« Reply #25 on: September 20, 2013, 12:25:00 PM »
what you just said does not make any sense, if they would want this to work they would delete the "appmarket" icon and just make a icon for the ATM, put the stock cydia ( just the icon on springboard ) and leave the appstore the way it is on stock ios 3.1.3 ( there is no need for the backup icon because it does not work any more  :( )
way would you port the ios 4 one? that would just take time for the same result you would get from this.

My suggestion for developers just was
- grab AppStore App from 4.2.1 and put in WD6 3.1.3
- if AppStore App from 4.2.1 runs on WD6 3.1.3 (I don't think, but who knows...) and lets the old app to be downloaded
-- then release a WD6 patch that adds AppStore4.2.1 in the WD6 AppMarket (along with TimeMachine, Cydia, AppStore3.1.3, Backup)
« Last Edit: September 20, 2013, 01:42:29 PM by woc »

Offline leejenshil

  • Hero Member
  • ****
  • Posts: 180
  • Country: il
  • graphical disianer
    • View Profile
  • Device: iPhone 2G
  • My Computer: Windows
Re: App Store now allows Older App Versions Download!
« Reply #26 on: September 20, 2013, 02:05:46 PM »
My suggestion for developers just was
- grab AppStore App from 4.2.1 and put in WD6 3.1.3
- if AppStore App from 4.2.1 runs on WD6 3.1.3 (I don't think, but who knows...) and lets the old app to be downloaded
-- then release a WD6 patch that adds AppStore4.2.1 in the WD6 AppMarket (along with TimeMachine, Cydia, AppStore3.1.3, Backup)


i guess you didn't read the full post because it works with the stock ios 3 appstore app so there is no need to port

Offline woc

  • Member
  • **
  • Posts: 19
  • Country: it
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPhone 3G
  • My Computer: Mac
Re: App Store now allows Older App Versions Download!
« Reply #27 on: September 20, 2013, 02:37:29 PM »
i guess you didn't read the full post because it works with the stock ios 3 appstore app so there is no need to port

According to these quotes:

Well it looks like it isn't working on stock 3.1.3. I've tried Facebook, Twitter, and Instagram. I'll still browse around the Appstore and see if there's anything at all that would download

it works with 3g but you have to update it to 4.2.1 first  :-\

it does NOT work with the stock ios 3 appstore app so there is need to port

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
Porting iOS 4.2.1 App Store to 3.1.3
« Reply #28 on: September 20, 2013, 02:42:58 PM »
Porting it wouldn't do any good, if apple doesn't have any 3.1.3 compatible apps on the appstore (maybe they only started archiving them at the release of 4.x) :(  So then the apps still wouldn't download, or maybe it isn't the appstore that is the issue, but rather the system itself, which even then it does no help to change it to make the device think it is running 4.x (bad idea BTW, breaks lots of things).

Offline Ihatewindows

  • Hero Member
  • ****
  • Posts: 115
  • Country: us
  • Linux fanboy and master doxer
    • View Profile
    • FedoraFiles
  • Device: iPhone 3G
  • My Computer: Linux
Re: App Store now allows Older App Versions Download!
« Reply #29 on: September 20, 2013, 08:09:34 PM »
But is there a workaround for WD users?
For example let say I need Camera 3D Pro that was developed for 3.1.3 too (and it's missing in TimeMachine).
Since Whited00r AppMarket/AppStore doesn't support the feature, could it be possible to download the old version via iTunes and than synch with WD6 iPhone?

I'm sure someone will hack it and port it in due time. If that is the case, 1 of 3 things will happen to ATM

The numbers of apps in ATM will skyrocket
ATM will be removed because it is no longer needed
ATM will link to the older iOS 3 compatible apps on the App Store.

In any case this is a game changer. One thing that worries me though is that Apple doesn't normally do something without a reason. IDK, maybe I'm over thinking it.

EDIT: bcooperizcool just posted

It will be interesting to find out for sure, but they probably do have archives of the iOS 3 compatible apps.
« Last Edit: September 20, 2013, 08:11:38 PM by Ihatewindows »
Please remember to dispose of hazardous material properly.