Author Topic: How to install Facebook Messenger on WD7?  (Read 2419 times)

Offline lythehung

  • Senior Member
  • ***
  • Posts: 28
  • Country: vn
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPhone 3G
  • My Computer: Windows
How to install Facebook Messenger on WD7?
« on: January 05, 2014, 08:13:39 AM »
how is install facebook messenger in WD7??????

Edit by bcooperizcool to provide more keywords in the title :)
« Last Edit: January 05, 2014, 06:25:03 PM by bcooperizcool »

Offline akhil268

  • Jr. Team Member
  • Senior Member
  • ****
  • Posts: 56
  • Country: in
  • Whited00r User
    • View Profile
  • Device: iPhone 2G
  • My Computer: Windows
Re: How to install Facebook Messenger on WD7?
« Reply #1 on: January 05, 2014, 10:27:13 AM »
how is install facebook messenger in WD7??????
Facebook messenger is not compatible for ios 3.1.3.so you cant install it in wd7.
[email protected] whitedoor hindi forum,working with (iha),doing Engineering
[email protected]

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
Re: How to install Facebook Messenger on WD7?
« Reply #2 on: January 05, 2014, 06:30:44 PM »
You cannot install apps that require a higher firmware than what the device is currently running. You also cannot run a higher firmware on your device, or make apps that require a higher firmware work on an older firmware.

This is explained in the Whited00r 6 - FAQ & Troubleshooting - READ BEFORE POSTING!

Quote
Why can't I install Apps that Requires iOS 4.3 or upgrade above iOS 4.2.1?

iOS 4.3 and above and apps that requires iOS 4.3 are using binaries CPU instructions sets for newer devices equipped with ARMv7 CPU & faster GPU and only those Apple devices have it:
ARMv7s = iPhone 5, iPad 4
ARMv7  = iPhone 3GS, iPhone 4, iPhone 4S, iPod Touch 3G, 4G & 5G, iPad, iPad 2, iPad 3 & iPad Mini.

Apple Devices with the ARMv6 CPU supported by Whited00r & App Time Machine but not by Apple anymore and dropped slowly & surely by iTunes  :-\

    iPod Touch 1G or 1st Generation  - max iOS 3.1.3
    Original iPhone 2G or 1st Gen - max iOS 3.1.3

    iPod Touch 2G or 2nd Gen - max iOS 4.2.1
    iPhone 3G or 2nd Gen - max iOS 4.2.1 but it's dog-slow, the very limit of what that hardware can take. Whited00r is based on a tweaked iOS 3.1.3 because it is much more fluid with plenty of free available RAM to run apps.

Apple could easily require that app developers include iOS backward compatibility to be eligible to iTunes App Store but they decided not to.  :-\   Apple makes the Xcode software that developers are using to create apps and removed support for ARMv6 binaries compatibility in their Xcode 4.5 version (see Mac Developer Library - Xcode Release Notes for technical details). Apparently they re-enabled ARMv6 binaries compatibility in the current Xcode 4.5.2 according to this.

Seeing as that Facebook Messenger requires at least iOS4.3.3 (or maybe 5.x), you cannot install it :(