Author Topic: WD7.1 Bugs on 1st gen iPhone  (Read 8618 times)

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
Re: WD7.1 Bugs on 1st gen iPhone
« Reply #15 on: April 04, 2014, 05:20:21 AM »
I don't know why spotlight would crash the phone :o  Especially when enabled, disabled maybe as a tweak messes with it then, but enabled, I don't know :o

You can still have spotlight enabled page wise, and have the daemon itself disabled by installing "Spotlight Override" from Repod00r in Cydia and turning spotlight "On" the override switch "Off", although you may need to toggle the override switch on/off once to get the value to write to the file (after that don't worry about it).

Hmmm... I will look into fixing Assisitive Touch rather than doing a workaround ;) Don't want anything running away code wise!

I don't like messing with the lock screen animations, that's one of the big reasons the LS Bounce option crashes a lot :/  I will see what I can do though!

I don't want to end up making control center like SBSettings, although that would be cool and the thought did cross my mind to make it like that, and able to load up custom switches which even users could learn to make. I'm concerned what the speed will end up being once a whole bunch of options and switches start getting built for it :(

Hmmm... Maybe it is something else to do with the longer sleep of the device then, not wifi.  I will see if there are other things relating to that which could cause a crash.

Not sure for the PIN entry buttons, I never get that screen on my device so I can't ever test that :(

Notification badges weren't really looked into as the icon animation is of itself a beta option in a way. Was just done in a day or two just for fun on my part to see what could be done, and cleaned up as much as I could. Seeing it wasn't an essential feature and wasn't needed to fix crash wise, it was put on the end of the list of things to do (although the code for icon animations was changed around a little bit and optimized more). We focused on the stability and the major overall graphics, such as the buttons for done, send, okay and such, as well as other readability improvements for white on white text being removed more. :(  Icon animation code and the notification badge bug kind of was forgotten in all that :(

Offline Panwaffles

  • Senior Member
  • ***
  • Posts: 29
  • Country: cs
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPhone 2G
  • My Computer: Windows
Re: WD7.1 Bugs on 1st gen iPhone
« Reply #16 on: April 11, 2014, 10:30:31 AM »
The crashes on incoming calls have become more frequent for some reason, or I'm just being unlucky. It crashes on about 3rd-4th call on average now. In addition, once I receive an SMS and I go into the Messages, a pop-up appears saying "Could not activate cellular network data".

I've disabled the Control Center, Spotlight Search, Sara, App Switcher, Location Services and Bluetooth.

Offline iTechy21

  • Bashing the shell
  • Global Moderator
  • SuperHero Member
  • *****
  • Posts: 1675
  • Country: gb
  • Well errr... Stuff :3
    • View Profile
    • My Blog
  • Device: iPod Touch 1G
  • My Computer: Windows
Re: WD7.1 Bugs on 1st gen iPhone
« Reply #17 on: April 11, 2014, 05:23:24 PM »
The crashes on incoming calls have become more frequent for some reason, or I'm just being unlucky. It crashes on about 3rd-4th call on average now. In addition, once I receive an SMS and I go into the Messages, a pop-up appears saying "Could not activate cellular network data".

I've disabled the Control Center, Spotlight Search, Sara, App Switcher, Location Services and Bluetooth.
Do you have the patch for whited00r 7.1 on Cydia?
Follow me on twitter! | Subscribe to my YouTube Channel! | Follow my blog!
Please Read all the stickies if you're new. And follow the rules, please :)

Offline Panwaffles

  • Senior Member
  • ***
  • Posts: 29
  • Country: cs
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPhone 2G
  • My Computer: Windows
Re: WD7.1 Bugs on 1st gen iPhone
« Reply #18 on: April 11, 2014, 07:18:53 PM »
Yep, unless there's a newer one.

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
Re: WD7.1 Bugs on 1st gen iPhone
« Reply #19 on: April 11, 2014, 07:55:53 PM »
The crashes on incoming calls have become more frequent for some reason, or I'm just being unlucky. It crashes on about 3rd-4th call on average now. In addition, once I receive an SMS and I go into the Messages, a pop-up appears saying "Could not activate cellular network data".

I've disabled the Control Center, Spotlight Search, Sara, App Switcher, Location Services and Bluetooth.

Well that isn't good. :(  with control center disabled, there shouldn't be anything that crashes the device on receiving a call.  Try disabling the banner notification tweak as well, just to see if that stops it. 

The could not activate cellular data network may be related to if you have the "Cellular Data" option disabled in the settings...

Offline Panwaffles

  • Senior Member
  • ***
  • Posts: 29
  • Country: cs
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPhone 2G
  • My Computer: Windows
Re: WD7.1 Bugs on 1st gen iPhone
« Reply #20 on: April 11, 2014, 08:02:32 PM »
I disabled the banner notifications just now, will see how it goes. Turned on Cell Data in the settings too, for the SMS stuff.

Offline Panwaffles

  • Senior Member
  • ***
  • Posts: 29
  • Country: cs
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPhone 2G
  • My Computer: Windows
Re: WD7.1 Bugs on 1st gen iPhone
« Reply #21 on: April 14, 2014, 12:18:24 PM »
Follow-up post:

It started crashing on it's own now. I end up seeing the loading circle when it goes out of standby and straight into Safe Mode. :( It doesn't happen right away, usually takes some time.

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
Re: WD7.1 Bugs on 1st gen iPhone
« Reply #22 on: April 14, 2014, 07:30:03 PM »
Follow-up post:

It started crashing on it's own now. I end up seeing the loading circle when it goes out of standby and straight into Safe Mode. :( It doesn't happen right away, usually takes some time.

Well that isn't good, what is the complete list of configuration for what you have enabled/disabled? (just the features page for now...)

Offline Panwaffles

  • Senior Member
  • ***
  • Posts: 29
  • Country: cs
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPhone 2G
  • My Computer: Windows
Re: WD7.1 Bugs on 1st gen iPhone
« Reply #23 on: April 14, 2014, 11:02:52 PM »
Wallpaper - On
Folders - Off
Backgrounder - Off
App Switcher - Disabled
Sara - Off
Banner Notifications - Off
Safari Unibar - Off
Control Center - Off
Assistive Touch - Off
Cell Data - On

It hasn't happened since I wrote the previous post, but I've seen it occur on at least three occasions.

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
Re: WD7.1 Bugs on 1st gen iPhone
« Reply #24 on: April 15, 2014, 04:47:24 AM »
Do you have "Lockscreen Bounce" enabled under the visual settings?

Offline Panwaffles

  • Senior Member
  • ***
  • Posts: 29
  • Country: cs
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPhone 2G
  • My Computer: Windows
Re: WD7.1 Bugs on 1st gen iPhone
« Reply #25 on: April 15, 2014, 08:59:44 AM »
Do you have "Lockscreen Bounce" enabled under the visual settings?

Nope.

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
Re: WD7.1 Bugs on 1st gen iPhone
« Reply #26 on: April 16, 2014, 05:29:07 AM »
Nope.

Any extra tweaks installed from cydia?

Offline Panwaffles

  • Senior Member
  • ***
  • Posts: 29
  • Country: cs
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPhone 2G
  • My Computer: Windows
Re: WD7.1 Bugs on 1st gen iPhone
« Reply #27 on: April 16, 2014, 07:48:39 PM »
Nope, only that one patch.

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
Re: WD7.1 Bugs on 1st gen iPhone
« Reply #28 on: April 16, 2014, 08:01:34 PM »
Nope, only that one patch.

Was the screen locked while in-app?  High usage apps like games, facebook, or even the App Time Machine (which shouldn't be locked during an install/download by the way) could cause a crash.

Offline Panwaffles

  • Senior Member
  • ***
  • Posts: 29
  • Country: cs
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPhone 2G
  • My Computer: Windows
Re: WD7.1 Bugs on 1st gen iPhone
« Reply #29 on: April 16, 2014, 08:08:21 PM »
The only app I have is the account sync-code generator for a website, that's all, and I very rarely turn it on.