Author Topic: [Tutorial] How To Fix Bounce Back Animation Bug on Lockscreen (WD7.1)  (Read 3159 times)

Offline CPVideoMaker

  • Hero Member
  • ****
  • Posts: 445
  • Country: us
  • A lurker on these forums.
    • View Profile
    • My YouTube Channel!
  • Device: iPod Touch 2G
  • My Computer: Windows
So I finally got this fixed and it's quite simple (an I was ready to spend hours on this  ;D).

Step #1: Install iFile (please don't pirate it, support the developers).


Step #2: Launch it and Navigate to /var/mobile/Library/Preferences


Step #3: Tap "com.whited00r.wd7lockscreen.plist". You should see this


Step #4: Under the First Option. add this line of code:
Code: [Select]
<key>FadeSlide</key>
<true/>
Should look like this once added:


Step #5: Respring and enjoy your non-buggy lockscreen :D
Just here, back after being inactive for about a year... once more.

Offline iTechy21

  • Bashing the shell
  • Global Moderator
  • SuperHero Member
  • *****
  • Posts: 1675
  • Country: gb
  • Well errr... Stuff :3
    • View Profile
    • My Blog
  • Device: iPod Touch 1G
  • My Computer: Windows
Wow thanks for that :)
A very good toutorial thanks for the write up :D
Pinned as well thank you.
« Last Edit: May 20, 2014, 11:37:38 AM by itechy21 »
Follow me on twitter! | Subscribe to my YouTube Channel! | Follow my blog!
Please Read all the stickies if you're new. And follow the rules, please :)

Offline Sir Roven

  • Senior Member
  • ***
  • Posts: 56
  • Country: pt
  • Dev Android | Iphone 3G Intro
    • View Profile
  • Device: iPhone 3G
  • My Computer: Windows
Very good amazing find bro :)
Developer Android on XDA MediaTek Devices
Introducing to a world to old IDevices
_--_--_--_--_--_--_--_--_--_--_--_--_--_--_--_--_

Offline Sir Roven

  • Senior Member
  • ***
  • Posts: 56
  • Country: pt
  • Dev Android | Iphone 3G Intro
    • View Profile
  • Device: iPhone 3G
  • My Computer: Windows
Look i try make that changes but when i open plist file contain this should i make like your or mine is fine ?

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
   <key>Bouncy</key>
   <false/>
   <key>FadeSlide</key>
   <true/>
   <key>appID</key>
   <string>com.apple.mobileslideshow</string>
   <key>logStuff</key>
   <false/>
</dict>
</plist>
Developer Android on XDA MediaTek Devices
Introducing to a world to old IDevices
_--_--_--_--_--_--_--_--_--_--_--_--_--_--_--_--_

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
Yours is fine, it is just some devices I guess that don't have the fadeSlide key there for some odd reason :o

However, if you have this bug but do have that key, then there is a deeper issue at work there :(

Offline Sir Roven

  • Senior Member
  • ***
  • Posts: 56
  • Country: pt
  • Dev Android | Iphone 3G Intro
    • View Profile
  • Device: iPhone 3G
  • My Computer: Windows
No i dont have the problem :D
Developer Android on XDA MediaTek Devices
Introducing to a world to old IDevices
_--_--_--_--_--_--_--_--_--_--_--_--_--_--_--_--_

Offline Peyton24679

  • New Member
  • *
  • Posts: 2
  • Country: 00
  • Whited00r iPod iPhone User
    • View Profile
  • Device: Does Not Own iDevice ARMv6
  • My Computer: Windows
I never had to face this type of silly problems...i think a good user can save a lot of troubles like this

Offline iTechy21

  • Bashing the shell
  • Global Moderator
  • SuperHero Member
  • *****
  • Posts: 1675
  • Country: gb
  • Well errr... Stuff :3
    • View Profile
    • My Blog
  • Device: iPod Touch 1G
  • My Computer: Windows
I never had to face this type of silly problems...i think a good user can save a lot of troubles like this
Its to do with the pass-code I think and setting the ask for passcode after timer.
Follow me on twitter! | Subscribe to my YouTube Channel! | Follow my blog!
Please Read all the stickies if you're new. And follow the rules, please :)

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
No, this is an issue with the preference file not having a certain key and thus defaulting to false.  Happens even with the passcode disabled :(

However, not many users at all are getting this, and I really don't know why it happens to very few people vs everyone or a specific set of devices/configurations.

Offline MarioKartEpicness

  • IPA God
  • SuperHero Member
  • *****
  • Posts: 516
  • Country: us
  • MKE and Dog, reporting for duty!
    • View Profile
  • Device: Does Not Own iDevice ARMv6
  • My Computer: Windows
Nice find! I also heard that bug spray keeps if from being buggy.

haha? get it? :P
You see this dog? Yeah, she's my cute dog. (☞゚∀゚)☞

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
Re: [Tutorial] How To Fix Bounce Back Animation Bug on Lockscreen (WD7.1)
« Reply #10 on: June 19, 2014, 08:47:10 PM »
Nice find! I also heard that bug spray keeps if from being buggy.

haha? get it? :P

Slow clap  :D