Author Topic: Multitasking not truly working on whited00r 7  (Read 1292 times)

Offline hakimbomadadda

  • Junior Member
  • *
  • Posts: 4
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPhone 3G
  • My Computer: Windows
Multitasking not truly working on whited00r 7
« on: December 05, 2014, 01:52:33 AM »
I just installed whited00r on my iphone 3g.  I notice that although the multitasking feature works for some apps(safari), the majority of my apps quit and don't show up in the multitasking bar when I press the home button.  When I had IOS 4.2.1 with a multitasking tweak, the multitasking worked just fine.  I really only need multitasking so that I can listen to pandora while using my phone, but still, Im frustrated. ::)
Are there any solutions?  Any help would be appreciated.
Thanks in advance,
-Hakim

PS: Im using the IOS 6-styled Multitasking, not the IOS 7. 

Offline Paul

  • Member
  • **
  • Posts: 13
  • Country: gb
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPod Touch 2G
  • My Computer: Windows
Re: Multitasking not truly working on whited00r 7
« Reply #1 on: December 05, 2014, 08:45:09 AM »
have you enabled backgrounder?

Offline isfiisfar

  • Hero Member
  • ****
  • Posts: 368
  • Country: pk
  • "i m the weirdest person" says the pakistan times
    • View Profile
  • Device: iPod Touch 1G
  • My Computer: Windows
Re: Multitasking not truly working on whited00r 7
« Reply #2 on: December 05, 2014, 10:58:45 AM »
go to settings/wd settings and enable the backgrounder.. and in th eappswitcher choose manual multitasking...
then if u wanna background  any app just hold the home button for a few seconds it will show a message that backgrounder enabled now the app will be backgrounded.. enjoy :P :P
i love my ipod 1g
add me on fb https://www.facebook.com/muhmmad.isfar
or kik me @ isfiisfar

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
Re: Multitasking not truly working on whited00r 7
« Reply #3 on: December 07, 2014, 06:55:39 AM »
Welcome to the forums :)

Because whited00r is not based on 4.2.1+, and only on 3.1.3, we don't have any of the native functions that higher firmwares have.  So true multitasking like you are used to is not possible.  However, you can use backgrounder to force apps to run as if they were still open. However, this eats up memory and resources very quickly because it isn't native and the apps are not built to use it in a native manner like they are on iOS 4 (iOS 4 keeps a single thread process open, and apps cater to that, backgrounder keeps whole apps open because they can't use jailbreak API on the App Store - to put it simply).  There is no way to make the native method work on older firmwares :(

If you do want it, go to the whited00r settings and make sure "Sara" is disabled, and then choose "Manual Multitasking" instead of the "iOS 7 App Switcher", and apply settings.

To background apps, hold down the home button while in an app and it should show a popup saying backgrounding enabled. To disable it, hold the home button again while in the app (or double tap the home button and hold on an icon and tap the red "-" on the app).  You can also enable a button to send apps to the background if you go to the advanced visual settings in the whited00r settings and turn that option on.  (need to have the manual multitasking enabled and settings applied for that first before it will show up).

Offline hakimbomadadda

  • Junior Member
  • *
  • Posts: 4
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPhone 3G
  • My Computer: Windows
Re: Multitasking not truly working on whited00r 7
« Reply #4 on: December 18, 2014, 03:35:28 AM »

go to settings/wd settings and enable the backgrounder.. and in th eappswitcher choose manual multitasking...
then if u wanna background  any app just hold the home button for a few seconds it will show a message that backgrounder enabled now the app will be backgrounded.. enjoy :P :P
Wow do I feel useless  ;D.  I should really read up more before I do these things.  Thanks, what you told me works.  I would also like to thank all the other people to responded to this for taking your time to answer such questions.  :D

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
Re: Multitasking not truly working on whited00r 7
« Reply #5 on: December 19, 2014, 07:22:38 AM »

Wow do I feel useless  ;D.  I should really read up more before I do these things.  Thanks, what you told me works.  I would also like to thank all the other people to responded to this for taking your time to answer such questions.  :D

No worries, the backgrounder option doesn't actually show up unless you enabled manual multitasking and applied the settings anyway (or advanced config), as it is meant to be more of a behind the scenes thing. Only problem was that the little information popups we give you when you tap on the names of the switches, doesn't actually work for the multitasking! :(

Offline Chris M.

  • Hero Member
  • ****
  • Posts: 223
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPod Touch 2G
  • My Computer: Windows
Re: Multitasking not truly working on whited00r 7
« Reply #6 on: July 13, 2016, 12:35:53 PM »
Welcome to the forums :)

Because whited00r is not based on 4.2.1+, and only on 3.1.3, we don't have any of the native functions that higher firmwares have.  So true multitasking like you are used to is not possible.  However, you can use backgrounder to force apps to run as if they were still open. However, this eats up memory and resources very quickly because it isn't native and the apps are not built to use it in a native manner like they are on iOS 4 (iOS 4 keeps a single thread process open, and apps cater to that, backgrounder keeps whole apps open because they can't use jailbreak API on the App Store - to put it simply).  There is no way to make the native method work on older firmwares :(

If you do want it, go to the whited00r settings and make sure "Sara" is disabled, and then choose "Manual Multitasking" instead of the "iOS 7 App Switcher", and apply settings.

To background apps, hold down the home button while in an app and it should show a popup saying backgrounding enabled. To disable it, hold the home button again while in the app (or double tap the home button and hold on an icon and tap the red "-" on the app).  You can also enable a button to send apps to the background if you go to the advanced visual settings in the whited00r settings and turn that option on.  (need to have the manual multitasking enabled and settings applied for that first before it will show up).
i tried backgrounder with the iOS 7 style app switcher and it works very well too :D