Author Topic: Suggestion for the new Whited00r!  (Read 1186 times)

Offline DooMFeaR

  • Senior Member
  • ***
  • Posts: 27
  • Country: ro
    • View Profile
  • Device: iPhone 2G
  • My Computer: Linux
Suggestion for the new Whited00r!
« on: April 21, 2015, 01:19:27 PM »
If a new whited00r will come out, please make it run on iPhone 2G. I saw whited00r 7 won't run on iPhone 2G, only whited00r 6. Thank you :)

Offline [email protected]

  • SuperHero Member
  • *****
  • Posts: 617
  • Country: in
  • Old is Smart!
    • View Profile
  • Device: iPhone 3G
  • My Computer: Windows
Re: Suggestion for the new Whited00r!
« Reply #1 on: April 21, 2015, 03:53:03 PM »
Whited00r 7 WILL RUN ON iPhone 2G....
Please check the download page again to get it...
New Thinking New Possiblities.
Proud owner of the legendary iPhone 3G.
And Proud Owner of the best budget phone Xiaomi Redmi Note 3 and iPad 3

Offline DooMFeaR

  • Senior Member
  • ***
  • Posts: 27
  • Country: ro
    • View Profile
  • Device: iPhone 2G
  • My Computer: Linux
Re: Suggestion for the new Whited00r!
« Reply #2 on: April 21, 2015, 04:22:52 PM »
Whited00r 7 WILL RUN ON iPhone 2G....
Please check the download page again to get it...

Sorry buddy, but I tried before! Whited00r 7.1 doesn't support iPhone 2G ;). Believe me! It works great on iPhone 3G, but not on 2G.

Offline [email protected]

  • SuperHero Member
  • *****
  • Posts: 617
  • Country: in
  • Old is Smart!
    • View Profile
  • Device: iPhone 3G
  • My Computer: Windows
Re: Suggestion for the new Whited00r!
« Reply #3 on: April 22, 2015, 01:52:58 AM »
Now you believe me it does support iPhone 2G and it always will
If you want check it for yourself www.whited00r.com/iPhone2G?lang=en
If you have any problems installing it please ask us !
New Thinking New Possiblities.
Proud owner of the legendary iPhone 3G.
And Proud Owner of the best budget phone Xiaomi Redmi Note 3 and iPad 3

Offline iTechy21

  • Bashing the shell
  • Global Moderator
  • SuperHero Member
  • *****
  • Posts: 1675
  • Country: gb
  • Well errr... Stuff :3
    • View Profile
    • My Blog
  • Device: iPod Touch 1G
  • My Computer: Windows
Re: Suggestion for the new Whited00r!
« Reply #4 on: April 22, 2015, 07:28:04 AM »
Whited00r 7 will RUN on the iPhone 2g and iPod touch 1G. There will be no issues as it is officially supported by Whited00r!!! 
Follow me on twitter! | Subscribe to my YouTube Channel! | Follow my blog!
Please Read all the stickies if you're new. And follow the rules, please :)

Offline DooMFeaR

  • Senior Member
  • ***
  • Posts: 27
  • Country: ro
    • View Profile
  • Device: iPhone 2G
  • My Computer: Linux
Re: Suggestion for the new Whited00r!
« Reply #5 on: April 22, 2015, 10:35:38 AM »
Thank you guys! I think whited00r doesn't support iPhone 3GS. Check my other topic please http://www.whited00r.com/forum/index.php/topic,12601.msg107768.html#msg107768

Offline JustinCase

  • An Agent of the System...
  • Global Moderator
  • SuperHero Member
  • *****
  • Posts: 3136
  • Country: kp
  • Here since WD 3.x
    • View Profile
    • Whited00rDev
  • Device: iPhone 2G
  • My Computer: Windows
Re: Suggestion for the new Whited00r!
« Reply #6 on: April 23, 2015, 03:18:42 AM »
You do know that the iPhone 2G and 3GS are two different devices........
I get on every now and then to check up
Go ahead and download Whited00r 8 BETA if you haven't yet: http://goo.gl/AFZIUT <------

Offline DooMFeaR

  • Senior Member
  • ***
  • Posts: 27
  • Country: ro
    • View Profile
  • Device: iPhone 2G
  • My Computer: Linux
Re: Suggestion for the new Whited00r!
« Reply #7 on: April 23, 2015, 03:10:38 PM »
You do know that the iPhone 2G and 3GS are two different devices........

Yeah, but its weird. Whited00r 7.1 will work great on iPhone 2G but not on 3GS?

Offline isfiisfar

  • Hero Member
  • ****
  • Posts: 368
  • Country: pk
  • "i m the weirdest person" says the pakistan times
    • View Profile
  • Device: iPod Touch 1G
  • My Computer: Windows
Re: Suggestion for the new Whited00r!
« Reply #8 on: April 23, 2015, 06:10:31 PM »
Yeah, but its weird. Whited00r 7.1 will work great on iPhone 2G but not on 3GS?
its cauz WD doesnt yet support iphone 3gs.. but it support iphone 3g nd 2g nd ipo 1g,2g :D :P
i love my ipod 1g
add me on fb https://www.facebook.com/muhmmad.isfar
or kik me @ isfiisfar

Offline MarioKartEpicness

  • IPA God
  • SuperHero Member
  • *****
  • Posts: 516
  • Country: us
  • MKE and Dog, reporting for duty!
    • View Profile
  • Device: Does Not Own iDevice ARMv6
  • My Computer: Windows
Re: Suggestion for the new Whited00r!
« Reply #9 on: April 25, 2015, 03:29:06 PM »
Yeah, but its weird. Whited00r 7.1 will work great on iPhone 2G but not on 3GS?
It's not that much work to make it work for iOS 6 or the other devices! Lazy! >:(

No, we aren't lazy. Whited00r 7 took 6+ months of development, reverse engineering and testing/designing to get working.
It's not as easy as just modifying some things and suddenly it works. We want to do quality work, and even if we didn't it would still face the following problems:
New API - Yes, we may have new API to work with, it also means the old code could become inefficient, or not work as designed originally
New Classes - New classes means things that we used before could be obsolete, or not even exist anymore.
Changes to existing Classes - This means things we have currently hooked or use, and spent ages figuring out, no longer behave as expected, exist, or even do the same things, or else aren't the quickest or best, or the cleanest way to do it anymore.
So, if we were to do it for newer firmwares, we would have to recode everything again and again and reverse engineer for each iOS version. On each new iOS, there will be any number of unpredictable challenges or roadblocks, meaning it could take even longer than whited00r 7 did. That's for each iOS we add support for.

The issues above are a big thing, but also, there is the problem of time. Whited00r is done for free, only for these older devices because it's not a whole set of new devices (thus requiring all the same work all over again).   We do this in our free time, but the developing team are all adults and need to make a living. Pouring all our free time (and even not the free time) into this sort of thing, to get nothing anywhere near what would be logical in return is stupid on our part.   We can't logically keep giving away everything for free if we were to support new devices. (even doing it for whited00r is kind of silly, but we do it for you. ).  No, lite versions of things wouldn't work either. You can't get anything reasonable with a lite version of this sort of thing and still have the incentive to upgrade to the full version and make the right sort of revenue to make this smart for us to keep doing.

As is, we keep supporting 3.1.3 only, and only on the current set of devices :)  Maybe, maybe at some point in the future we will start other projects, if we figure out a good balance.  Not saying we won't ever do that, but not soon that I know of. It took us that long without needing to constantly troubleshoot super-active forums (which they are now seeing we just released an update).  We also need a rest ;) (only human after all, for most of us)
You see this dog? Yeah, she's my cute dog. (☞゚∀゚)☞

Offline iTechy21

  • Bashing the shell
  • Global Moderator
  • SuperHero Member
  • *****
  • Posts: 1675
  • Country: gb
  • Well errr... Stuff :3
    • View Profile
    • My Blog
  • Device: iPod Touch 1G
  • My Computer: Windows
Re: Suggestion for the new Whited00r!
« Reply #10 on: April 25, 2015, 08:31:30 PM »
Follow me on twitter! | Subscribe to my YouTube Channel! | Follow my blog!
Please Read all the stickies if you're new. And follow the rules, please :)

Offline dellieuxr

  • Hero Member
  • ****
  • Posts: 165
  • Country: fr
    • View Profile
    • My Twitter
  • Device: iPod Touch 2G
  • My Computer: Windows
Re: Suggestion for the new Whited00r!
« Reply #11 on: May 19, 2015, 04:10:34 PM »
Yeah, but its weird. Whited00r 7.1 will work great on iPhone 2G but not on 3GS?
Whited00r doesn't support iPhone 3GS because it's not an armv6 device !
It's highest version is iOS 6.1.x, so it doesn't really need Whited00r in my opinion...

EDIT : nevermind, MarioKartEpicness answered your question really well :)
Typhlosion <3