Author Topic: Enable MMS iPhone 2G  (Read 71267 times)

Offline Gawernator

  • @Whited00r Twitter
  • SuperHero Member
  • *****
  • Posts: 1240
  • Country: us
  • Whited00r God
    • View Profile
    • Whited00r
  • Device: iPhone 2G
  • My Computer: Mac
Enable MMS iPhone 2G
« on: April 03, 2011, 12:47:58 AM »
I remembered out of the blue that I had a copy of the manually patched commcenter on my harddrive from an older FW release, I backed it up and I never do normally <!-- s:lol: -->:lol:<!-- s:lol: -->
Here you go:  <!-- m -->http://fileape.com/dl/LLqIRGYX5wQS79Kt<!-- m -->

Make sure to rename it to CommCenter and give ownership and permissions root:wheel
0755 respectively

To replace the CommCenter, navigate to /System/Library/PrivateFrameworks/CoreTelephony.framework/Support

and paste in the new CommCenter file. 
***THIS IS IMPORTANT***
With iFile on your phone or via SSH set the CommCenter file to
Owner: root
Group: wheel

permissions:
user: Read/Write/Execute
Group: Read/Execute
World: Read/Execute

Then reboot your phone ONLY after double checking those permissions are correct or your phone will boot loop forever and need to be restored.

EDIT again: Ok, this time I uploaded as a .zip file so that should help fix any download issues.  This should work for everyone have fun <!-- s:) -->:)<!-- s:) -->
« Last Edit: May 04, 2011, 04:11:29 AM by RagingNinja »
iPhone 2G 16GB + iPhone 4 32 GB White <Gawernator> iPhones are made with maple syrup in the processor <Gawernator> in Canada <Gawernator> it causes slowdowns
@Whited00r on Twitter

Offline wojnar0

  • New Member
  • *
  • Posts: 2
    • View Profile
Re: Enable MMS iPhone 2G
« Reply #1 on: April 03, 2011, 04:23:36 PM »
@Gwernator

Please upload file to another server.

Thanks
« Last Edit: January 01, 1970, 12:00:00 AM by Guest »

Offline Gawernator

  • @Whited00r Twitter
  • SuperHero Member
  • *****
  • Posts: 1240
  • Country: us
  • Whited00r God
    • View Profile
    • Whited00r
  • Device: iPhone 2G
  • My Computer: Mac
Re: Enable MMS iPhone 2G
« Reply #2 on: April 03, 2011, 08:14:59 PM »
Why? Fileape is fast and free
« Last Edit: January 01, 1970, 12:00:00 AM by Guest »
iPhone 2G 16GB + iPhone 4 32 GB White <Gawernator> iPhones are made with maple syrup in the processor <Gawernator> in Canada <Gawernator> it causes slowdowns
@Whited00r on Twitter

Offline haykulik9

  • Member
  • **
  • Posts: 20
    • View Profile
Re: Enable MMS iPhone 2G
« Reply #3 on: April 04, 2011, 12:43:44 AM »
OMG i think i put permssions wrong!! so its supposed to be 0777? i did 0775 and i didnt rename the file. dammit! is there a way to fix this???
« Last Edit: January 01, 1970, 12:00:00 AM by Guest »

Offline nizam1205

  • Member
  • **
  • Posts: 15
    • View Profile
Re: Enable MMS iPhone 2G
« Reply #4 on: April 04, 2011, 01:29:56 AM »
Doesn't the 0777 will make all permissions to read/write/execute??

haykulik9
I think u should not reboot your phone before amending the permissions first. Try amend the permissions using ifile. I learn it the hard way.. Restored to 4.1 copy the CommCentre file and Restored back to 4.3..

Shish...I get excited and didnt wait for gawernator file.. Haha...
« Last Edit: January 01, 1970, 12:00:00 AM by Guest »

Offline haykulik9

  • Member
  • **
  • Posts: 20
    • View Profile
Re: Enable MMS iPhone 2G
« Reply #5 on: April 04, 2011, 01:55:41 AM »
Quote from: "nizam1205"
Doesn't the 0777 will make all permissions to read/write/execute??

haykulik9
I think u should not reboot your phone before amending the permissions first. Try amend the permissions using ifile. I learn it the hard way.. Restored to 4.1 copy the CommCentre file and Restored back to 4.3..

Shish...I get excited and didnt wait for gawernator file.. Haha...

thats what i thought. damm im about to do it again right now. ive restored. idk what to do!!! 777 duznt seem right it duznt match the permissions he said earlier.

<Mon Apr 04, 2011 3:03 am> [hr:2iu3p0ym][/hr:2iu3p0ym]

ok i wanted to take the risk. i reinstalled it with permissions 775 and renamed "CommCenterMMS" to "CommCenter". it rebooted fine. (thanks God!!!) but id nt get it. isnt it supposed to enable mms? or are we still supposed to download the activate thing?
« Last Edit: January 01, 1970, 12:00:00 AM by Guest »

Offline nizam1205

  • Member
  • **
  • Posts: 15
    • View Profile
Re: Enable MMS iPhone 2G
« Reply #6 on: April 04, 2011, 03:42:55 AM »
FYI this is to enable the MMS function, result may vary... Mine work fine and can straight away mms... Haha, i guess we are in the same boat.. hihihi... better save the patch, if there is another WD update withoit MMS we would know what to do right???  Haha

Sir Gawernator..
I've tried the 0777 permission but it seem that my phone cannot boot. I tried changing to 0755 and it worked fine..

And i think this is the most safest and hassle free to enable MMS. What say u??

This is the patched CommCentre from WD4.1
http://forum.lowyat.net/index.php?act=A ... id=2134426
« Last Edit: April 04, 2011, 03:55:08 AM by nizam1205 »

Offline Gawernator

  • @Whited00r Twitter
  • SuperHero Member
  • *****
  • Posts: 1240
  • Country: us
  • Whited00r God
    • View Profile
    • Whited00r
  • Device: iPhone 2G
  • My Computer: Mac
Re: Enable MMS iPhone 2G
« Reply #7 on: April 04, 2011, 03:49:11 AM »
Sorry, I wrote that first part wrong but wrote it right in the edit! LOL 0755 is correct.
« Last Edit: January 01, 1970, 12:00:00 AM by Guest »
iPhone 2G 16GB + iPhone 4 32 GB White <Gawernator> iPhones are made with maple syrup in the processor <Gawernator> in Canada <Gawernator> it causes slowdowns
@Whited00r on Twitter

Offline nizam1205

  • Member
  • **
  • Posts: 15
    • View Profile
Re: Enable MMS iPhone 2G
« Reply #8 on: April 04, 2011, 04:42:02 AM »
:D  :mrgreen:  :lol:
« Last Edit: January 01, 1970, 12:00:00 AM by Guest »

Offline haykulik9

  • Member
  • **
  • Posts: 20
    • View Profile
Re: Enable MMS iPhone 2G
« Reply #9 on: April 04, 2011, 11:43:22 AM »
Uhh its ok Gawernator. All it cost me was i phone wipe with the delete of all my precious files. No biggie lol.

<Mon Apr 04, 2011 8:59 pm> [hr:1j6pikhd][/hr:1j6pikhd]

Quote from: "nizam1205"
FYI this is to enable the MMS function, result may vary... Mine work fine and can straight away mms... Haha, i guess we are in the same boat.. hihihi... better save the patch, if there is another WD update withoit MMS we would know what to do right???  Haha

Sir Gawernator..
I've tried the 0777 permission but it seem that my phone cannot boot. I tried changing to 0755 and it worked fine..

And i think this is the most safest and hassle free to enable MMS. What say u??

This is the patched CommCentre from WD4.1
http://forum.lowyat.net/index.php?act=A ... id=2134426

THANK YOU SO MUCH!!! ive been trying to get this to work for the past two weeks. PPl if u want it to work use nizam's file. No offense but gawernator's duznt work =P
« Last Edit: January 01, 1970, 12:00:00 AM by Guest »

Offline nizam1205

  • Member
  • **
  • Posts: 15
    • View Profile
Re: Enable MMS iPhone 2G
« Reply #10 on: April 05, 2011, 01:31:46 AM »
That's not my file actually.
It's our's..

Coz i extract it from the official Whited00r 4.1.
 ;)  ;)
« Last Edit: January 01, 1970, 12:00:00 AM by Guest »

Offline haykulik9

  • Member
  • **
  • Posts: 20
    • View Profile
Re: Enable MMS iPhone 2G
« Reply #11 on: April 05, 2011, 02:40:42 AM »
Oh lols ok. Anyways thanks. I need help with sonething else though. Does whitedoor have like a problem with saving cookies while browsing on a proxy? Cuz i use ifailhard.com for free internet but when i go into FB and navigate from the main page, it makes me log in all over again
« Last Edit: January 01, 1970, 12:00:00 AM by Guest »

Offline Gawernator

  • @Whited00r Twitter
  • SuperHero Member
  • *****
  • Posts: 1240
  • Country: us
  • Whited00r God
    • View Profile
    • Whited00r
  • Device: iPhone 2G
  • My Computer: Mac
Re: Enable MMS iPhone 2G
« Reply #12 on: April 05, 2011, 02:57:55 AM »
I'm glad it works for you :)

P.S. The commcenter I posted is from WD V4.1 MMS too LOL

<Mon Apr 04, 2011 7:59 pm> [hr:o87k4yai][/hr:o87k4yai]

Quote from: "haykulik9"
Uhh its ok Gawernator. All it cost me was i phone wipe with the delete of all my precious files. No biggie lol.

<Mon Apr 04, 2011 8:59 pm> [hr:o87k4yai][/hr:o87k4yai]

Quote from: "nizam1205"
FYI this is to enable the MMS function, result may vary... Mine work fine and can straight away mms... Haha, i guess we are in the same boat.. hihihi... better save the patch, if there is another WD update withoit MMS we would know what to do right???  Haha

Sir Gawernator..
I've tried the 0777 permission but it seem that my phone cannot boot. I tried changing to 0755 and it worked fine..

And i think this is the most safest and hassle free to enable MMS. What say u??

This is the patched CommCentre from WD4.1
http://forum.lowyat.net/index.php?act=A ... id=2134426

THANK YOU SO MUCH!!! ive been trying to get this to work for the past two weeks. PPl if u want it to work use nizam's file. No offense but gawernator's duznt work =P

Sorry about your phone.. but you DID make a backup of your data before trying this.. RIGHT?! :lol: Anyways, that's a good habit to have ;) I did write the more detailed permissions in the bottom part of the post so I guess you could've double checked :P
« Last Edit: January 01, 1970, 12:00:00 AM by Guest »
iPhone 2G 16GB + iPhone 4 32 GB White <Gawernator> iPhones are made with maple syrup in the processor <Gawernator> in Canada <Gawernator> it causes slowdowns
@Whited00r on Twitter

Offline mrcrfrz

  • Member
  • **
  • Posts: 16
    • View Profile
Re: Enable MMS iPhone 2G
« Reply #13 on: April 05, 2011, 04:00:46 AM »
hey guys i need some help. i followed Gawenator's intruction while using nizam's backup CommCenter. i quadruple checked before rebooting that my permission is 755. but when i rebooted it doesnt boot anymore. it stuck in the boot logo with the spinning wheel. i made sure that i got the correct permission before rebooting.

and after this do i need to install the activatmms in smart-mobile?  thanks
« Last Edit: January 01, 1970, 12:00:00 AM by Guest »

Offline nizam1205

  • Member
  • **
  • Posts: 15
    • View Profile
Re: Enable MMS iPhone 2G
« Reply #14 on: April 05, 2011, 04:15:58 AM »
Quote from: "mrcrfrz"
hey guys i need some help. i followed Gawenator's intruction while using nizam's backup CommCenter. i quadruple checked before rebooting that my permission is 755. but when i rebooted it doesnt boot anymore. it stuck in the boot logo with the spinning wheel. i made sure that i got the correct permission before rebooting.

and after this do i need to install the activatmms in smart-mobile?  thanks

Did you rename the file i attached? How do you copy the file to your phone?
« Last Edit: January 01, 1970, 12:00:00 AM by Guest »