Author Topic: [Broken] Redd00r for iPod Touch 2g and iPhone 3g  (Read 323928 times)

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
Re: [Broken] Redd00r for iPod Touch 2g and iPhone 3g
« Reply #945 on: August 24, 2014, 05:35:58 AM »
PLS work on redd00r or add a link for the older version!
Somehow whited00r or iphone 3g makes me annoyed just because it's on ios 3.1.3, not 4.2.1

Welcome to the forums :)

Have you read the Whited00r 7.1 FAQ/Bugs and Troubleshooting READ BEFORE POSTING?

It is explained in there why we do not make anything other than for 3.1.3 at this time.
Quote
Whited00r device support and future plans
Sorry if below sounds harsh, but it's the truth of how things are. Sometimes only bluntly saying things gets it through and makes people understand the full picture ;)

Will whited00r support any new devices like the iPad 1G, iPod touch 3G/4G, or the iPhone 3GS?
No. It won't. If there ever are any other things for those devices, it would be under another project name.

Why doesn't whited00r support those devices, or different iOS versions?
Too much work to develop for more and more devices.

It's not that much work to make it work for iOS 6 or the other devices! Lazy! >:(

No, we aren't lazy. Whited00r 7 took 6+ months of development, reverse engineering and testing/designing to get working.
It's not as easy as just modifying some things and suddenly it works. We want to do quality work, and even if we didn't it would still face the following problems:
  • New API - Yes, we may have new API to work with, it also means the old code could become inefficient, or not work as designed originally
  • New Classes - New classes means things that we used before could be obsolete, or not even exist anymore.
  • Changes to existing Classes - This means things we have currently hooked or use, and spent ages figuring out, no longer behave as expected, exist, or even do the same things, or else aren't the quickest or best, or the cleanest way to do it anymore.
So, if we were to do it for newer firmwares, we would have to recode everything again and again and reverse engineer for each iOS version. On each new iOS, there will be any number of unpredictable challenges or roadblocks, meaning it could take even longer than whited00r 7 did. That's for each iOS we add support for.

The issues above are a big thing, but also, there is the problem of time. Whited00r is done for free, only for these older devices because it's not a whole set of new devices (thus requiring all the same work all over again).   We do this in our free time, but the developing team are all adults and need to make a living. Pouring all our free time (and even not the free time) into this sort of thing, to get nothing anywhere near what would be logical in return is stupid on our part.   We can't logically keep giving away everything for free if we were to support new devices. (even doing it for whited00r is kind of silly, but we do it for you. ).  No, lite versions of things wouldn't work either. You can't get anything reasonable with a lite version of this sort of thing and still have the incentive to upgrade to the full version and make the right sort of revenue to make this smart for us to keep doing.

As is, we keep supporting 3.1.3 only, and only on the current set of devices :)  Maybe, maybe at some point in the future we will start other projects, if we figure out a good balance.  Not saying we won't ever do that, but not soon that I know of. It took us that long without needing to constantly troubleshoot super-active forums (which they are now seeing we just released an update).  We also need a rest ;) (only human after all, for most of us)

Offline T

  • Senior Member
  • ***
  • Posts: 29
  • Country: au
  • Whited00r iPod iPhone User
    • View Profile
  • Device: iPhone 3G
  • My Computer: Windows
Re: [Broken] Redd00r for iPod Touch 2g and iPhone 3g
« Reply #946 on: August 24, 2014, 11:29:55 AM »
The thing is, with an iphone 3g, I would still like to get ios 4 apps on whited00r, which is impossible with it running on whited00r
When I use iFile to change the string to 4.2.1 as suggested, the some of the apps on apptimemachine don't work.
Apps like iBooks for 4.2.1 are a lot more advanced than their ios 3.1.3 versions, and I can't have both working sametime! :'(

Also, is it possible to change the whited00r firmware to accept ios 4.2.1 and how? :)
« Last Edit: August 24, 2014, 11:33:00 AM by T »

Offline iTechy21

  • Bashing the shell
  • Global Moderator
  • SuperHero Member
  • *****
  • Posts: 1675
  • Country: gb
  • Well errr... Stuff :3
    • View Profile
    • My Blog
  • Device: iPod Touch 1G
  • My Computer: Windows
Re: [Broken] Redd00r for iPod Touch 2g and iPhone 3g
« Reply #947 on: August 24, 2014, 11:37:11 AM »
The thing is, with an iphone 3g, I would still like to get ios 4 apps on whited00r, which is impossible with it running on whited00r
When I use iFile to change the string to 4.2.1 as suggested, the some of the apps on apptimemachine don't work.
Apps like iBooks for 4.2.1 are a lot more advanced than their ios 3.1.3 versions, and I can't have both working sametime! :'(

Also, is it possible to change the whited00r firmware to accept ios 4.2.1 and how? :)
No it is not possible... And changing the string is not recommended as you found out it breaks some apps
Follow me on twitter! | Subscribe to my YouTube Channel! | Follow my blog!
Please Read all the stickies if you're new. And follow the rules, please :)

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
Re: [Broken] Redd00r for iPod Touch 2g and iPhone 3g
« Reply #948 on: August 25, 2014, 04:16:25 AM »
The thing is, with an iphone 3g, I would still like to get ios 4 apps on whited00r, which is impossible with it running on whited00r
When I use iFile to change the string to 4.2.1 as suggested, the some of the apps on apptimemachine don't work.
Apps like iBooks for 4.2.1 are a lot more advanced than their ios 3.1.3 versions, and I can't have both working sametime! :'(

Also, is it possible to change the whited00r firmware to accept ios 4.2.1 and how? :)

I know you would :(  I think a lot of people would too, but we explained why whited00r only is for 3.1.3 above (that plus the whole issue of keeping the forum organized between the iOS 3 and iOS 4 releases, which trust me, was a pain even with the different project names. People just didn't answer or didn't know what they had installed, and it's a whole new set of bugs too), and in the FAQ it explains why you can't get apps that require higher firmwares to work on older ones. 

Not possible to change it to accept iOS 4 either, because restoring to iOS 4 wipes out all whited00r related things (which wouldn't work on iOS 4 anyway, coded just for 3.1.3)


Offline iPH0NE_3GS

  • SuperHero Member
  • *****
  • Posts: 720
  • Country: us
  • 3GS BABY !
    • View Profile
  • Device: iPhone 2G
  • My Computer: Mac
Re: [Broken] Redd00r for iPod Touch 2g and iPhone 3g
« Reply #949 on: April 27, 2015, 11:49:26 PM »
What repo can i use this one http://applepie.indigo.dragon-dev.co.uk/Repo/ isn't working
Check out My "iOS 11 Theme For WD 7.1 " to make your WD 7.1 device look and Feel like iOS 11 !!

Offline iPH0NE_3GS

  • SuperHero Member
  • *****
  • Posts: 720
  • Country: us
  • 3GS BABY !
    • View Profile
  • Device: iPhone 2G
  • My Computer: Mac
[Broken] Redd00r for iPod Touch 2g and iPhone 3g
« Reply #950 on: May 08, 2015, 09:21:42 PM »

Common Questions and Issues
Q: When installing, I get an error saying I need iOS4.3.2, or I get a dependency error about preference loader?
A: This is because I am hosting a version of mobile substrate that works on the redd00r base firmware and only that firmware (for some reason the version on suarik's repo doesn't work on it). The only way to get cydia to use that version over the one on suarik's repo is to change the version number to be newer than the one on suarik's repo. Unfortunately, for everyone else, they will see the update in cydia and if they don't have mobilesubstrate already, they won't be able to install tweaks.

TO GET AROUND THIS:
1. Remove the "applepie.bplaced.net" repo.
2. Install mobilesubstrate (from suarik's repo)
3. Re-add my repo.
Sorry for the inconvenience.

Q: After adding the "applepie.bplaced.net" repo I get an update for mobilesubstrate, but I can't install it?
A: See above.


I removed the repo and looked up mobile substrate and I can't find it
« Last Edit: May 09, 2015, 12:59:16 PM by iPH0NE_3GS »
Check out My "iOS 11 Theme For WD 7.1 " to make your WD 7.1 device look and Feel like iOS 11 !!