Support - Whited00r Custom iOS for iPhone 2G, 3G & iPod Touch 1G & 2G > Troubleshooting - iPhone & iPod Touch 1G/2G/3G, Unlock & Jailbreak Problems & Issues

Whited00r 6 - GPS problem iPhone 3G Baseband 05.13.04, 05.15.04 & 06.15.00

(1/49) > >>

2013-05-26 PierreP Moderator edit: We may have found the solution but for the real GPS receiver only. Try this fix FIX - GPS problem iPhone 3G Baseband 05.13.04 and after that this GPS test method: App to Test GPS - MotionX-GPS Better than Google Maps

Native Maps app returning a "Your location could not determined" error in Whited00r 6:

And thank you in advance for reporting back in this thread about if it worked for you or not.  8)

Note that the iPhone 2G & iPod Touch 1 & 2G do not have a GPS receiver. They use a-GPS (or AGPS - Assisted GPS) to approximate your location by triangulation. The exact technical term is Trilateration.

It may take up to 12 minutes outdoor with a clear sky view using the iPhone 3G to get a lock on 4 satellites minimum which is necessary to be able to get the Altitude data & Accuracy under 47 meters as illustrated above.

Sadly, the a-GPS function permitting a fast approximate location in the native iOS Maps application & faster GPS chipset satellites lock was broken by Apple on iOS 3.1.3 (on which Whited00r is based for max speed & fluidity) because they changed the a-GPS servers' URL's starting on iOS 4+ and disabled access to the previous ones. Just like they are doing in iTunes with apps updates not supporting our older devices anymore.  :-\

The Whited00r team is working on finding a workaround and we will update this post as soon as we find a fix.

Quick approximate location in Maps & Location Services (Core location framework) does not work in Whited00r 6.  :-\

If your iPhone 3G has the > Settings > General > About > Modem Firmware (a.k.a. baseband) > 06.15.00 then the GPS receiver will never work because it is an iPad baseband & that iPad did not have a GPS receiver chip so it is not enabled. See step 3 here if you would like to downgrade to a real iPhone 3G modem firmware: [Solved] iPhone 3G iOS 4.2.1 Stuck in Baseband 05.15.04 - No Service

Do not waste your time changing basebands if your modem firmware is not the iPad 06.15.00 as it will not fix the a-GPS problem nor affect the GPS Receiver as proven by multiple tests I ran on 2 different iPhone 3G's.

The native Maps app will work on Whited00r 6 but only after you got a GPS satellite fix using one of the apps illustrated above which may take up to 12 minutes the first time you get a fix:


Original post:

Location services does not function at all on my iPhone 3G after i installed whited00r, but i can send and receive calls.

Originally running 4.2.1 baseband 05.15.04. Locked to carrier of the shipped SIM.
Jailbreaked and updated baseband to 06.15 with redsn0w 0.9.6b6
Downgraded baseband to 05.13.04 with redsn0w 0.9.14b1
Downgraded firmware to 3.1.2 stock, baseband was preserved.
Jailbreaked with blackra1n (without jailbreaking i wasn't able to install the whited00r-ipsw via iTunes).
Installed whited00r wd6 - unlocked.
Updated all the cydia files and ultrasn0w. Rebooted.

The phone is working perfectly, sending and receiving calls with non-shipped SIM-card.
But location services won't work at all, not even with external bluetooth GPS-dongle.
The phone will connect to the dongle but no functioning homing in the maps app.
I never see the little blue arrow, in fact no arrow at all, in the upper right corner.
Could this be a problem with some daemon not running properly, since I cant get a fix even with external GPS device?

Interestingly when i open the maps app and press the arrow, it first locates the approximate location of my wifi (probably sniffed by google i assume) and then shifts to the approximate location of where i used to live 1,5 years ago - the last time i used the iPhone 3G with the original shipped SIM!

Any ideas guys?

Try running this in terminal, it supposedly fixes location based bugs (if it does work I will send more instructions to keep it working). so, as root run this line by line:
launchctl unload /System/Library/LaunchDaemons/
launchctl load /System/Library/LaunchDaemons/

I have bb 05.13.04 and my GPS is not working  :( Just shows a big white circle, not exact location..

@ Gorkij - Welcome to the Whited00r forum! 

f0recast is a simple free standalone tool to instantly find essential iPhone info including Bootloader version and baseband. Works on Mac & Windows. Download the free f0recast & iREB tools here:

I just connected my iPhone 3G to my computer with iTunes closed, started the small standalone (means no install required) f0recast and it gave me all the essential info about the iPhone:

Could you make a similar screen capture and post it here?

My iPhone 3G running Whited00r 6 on Baseband 05.13.04 works absolutely fine, including the GPS which is really accurate. It was on bad iPad Baseband 06.15 before I downgraded it to a proper iPhone baseband.

Have you tried this: Hard Reset often solve many problems: hold both Home & Power buttons until the Apple logo appears and let go of the buttons & smell the roses while it is doing it's thing. 

No worries, hard reset will not change any of your info, tweaks & apps on the device.


--- Quote from: momircar11 on February 21, 2013, 02:56:41 PM ---I have bb 05.13.04 and my GPS is not working  :( Just shows a big white circle, not exact location..

--- End quote ---

You already posted the same thing here and got a reply.  whited00r 6 iPhone 3g Baseband 05.13.04 GPS Not Working?

Hi and thanx for the replies.
I ran the terminal commands in terminal as root but no GPS-fix afterwards. It only gets an approximate fix based on WiFi-location; if I turn WiFi off - not even approximate fix. No difference if I use internal or external GPS source. Weird isn't it?

I have done a hard reboot and no difference. I'll attach my f0recast result.


[0] Message Index

[#] Next page

Go to full version