Whited00r Forum

Support - Whited00r Custom iOS for iPhone 2G, 3G & iPod Touch 1G & 2G => Apps Compatible with iOS 3.1, 3.1.3, 4.1 & 4.2.1 => Topic started by: PierreP on December 16, 2012, 06:19:57 PM

Title: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: PierreP on December 16, 2012, 06:19:57 PM
********************************************

Update 2013-05-08: Currently in iTunes the new Instagram version 3.5.1 (https://itunes.apple.com/us/app/instagram/id389801252?mt=8) "Requires iOS 5.0 or later" so now they dropped support for iOS 4.3 also.  :-\

Update 2013-04-04: The Instagram server-side broke the backward compatibility and does not understand anymore the upload and delete photos instructions code made by older versions of the Instagram app for users who are already logged in into their accounts.

That would be very easy to fix by the Instagram engineers if they would really care about their users. If you have the same cannot upload or delete photos issue create an Instagram support ticket describing that as it is the only way to solve this problem as we cannot hack into Instagram/Facebook's servers.  :o

Edit 2013-04-03: Goddammit!  >:( Instagram was bought by Facebook (http://en.wikipedia.org/wiki/Instagram) and now Facebook broke it using their server-side checks so the millions of owners of Apple's iPhone 2G & 3G and iPod Touch 1G & 2G cannot loggin into their Instagram account using my tricks below to Sign Up because Login into your existing account is not working anymore as Instagram is blocking us on purpose.  :( 

(http://vaiofseries.com/whited00r/Error_Your_version_of_Instagram_is_out_of_date_iPhone_3G_PierreP.png)

The Instagram error says: "Your version of Instagram is out of date. Please upgrade your app in the App Store to sign up for Instagram."  but the current Instagram app in iTunes (https://itunes.apple.com/en/app/instagram/id389801252?mt=8) says: Requires iOS 5.0 or later and that means that iPhone 2G & 3G and iPod Touch 1G & 2G cannot use it because those Apple devices can't run any iOS above 4.2.1 because of their ARMv6 CPU limitations. See this sticky for more info about that: (it means a thread pinned at the top of the forum list) Whited00r 6 - FAQ & Troubleshooting - READ BEFORE POSTING! (http://www.whited00r.com/forum/index.php?topic=7258.0)

I have a iPhone 3G, didnt log out from my account, but as i tried to upload today a foto i came accross the same message!!

Last week i did upload some fotos, today i cannot!  :(

So we need to make a public protest campaign and kick the butt of both Instagram and Facebook Support like we did successfully here for WhatsApp: [50% Solved] WhatsApp WD6 Problem - Partially Working Update! (http://www.whited00r.com/forum/index.php/topic,7068.0.html)

I just used Google's Chrome browser on Windows 7 64-bit and added the free Instagram for Chrome extension (https://chrome.google.com/webstore/detail/instagram-for-chrome/opnbmdkdflhjiclaoiiifmheknpccalb/) to loggin my Instagram account then went to: Report a bug (http://help.instagram.com/help/instagram/508187779209820/) >>> Report a Broken Feature (http://help.instagram.com/help/instagram/421587617901336/) >>> First steps (http://help.instagram.com/370569449686414/) >>> scroll all the way down to Still no luck? >>> and finally after jumping through so many hoops click on the link: "we'll have you submit a bug report (https://www.facebook.com/help/contact/?id=364531043625021)".

(http://vaiofseries.com/whited00r/jumping-through-hoops.png)

 8)  I strongly suggest you do the same if you want Instagram working again on your iPhone 2G & 3G and iPod Touch 1G & 2G running Whited00r or iOS 3.1.3, 3.1.2, 4.0, 4.1 or iOS 4.2.1.  8)

Bug Report > Instagram version > Select Other as v2.5.0 is not listed anymore in the drop-down menu. (Instagram v2.5.0 is the last version working on iOS 3.1.2 and above and that's why it is the version currently available in App Time Machine > Photo & Video > Instagram.) Edit 2013-03-21: Instagram is blocking also the Instagram v2.5.1 app which requires iOS 4 and above and also Instagram v3.0.0 that requires iOS 4.2.1

What happened? > Select Logging in.

Then a text box will appear for writing your protest message. What I wrote as an example for you:

Quote
Hello, I cannot log into my Instagram account anymore on my iPhone 3G on iOS 3.1.3 running Instagram v2.5.0 which was running fine until YOU BROKE IT!

Now when I try to loggin it says: "Your version of Instagram is out of date. Please upgrade your app in the App Store to sign up for Instagram."

But it is a catch 22 because the current Instagram version in iTunes (https://itunes.apple.com/us/app/instagram/id389801252?mt=8) is NOT COMPATIBLE with any iOS lower than iOS 5.0 so basically your are saying to millions of owners of Apple's iPhone 2G & 3G and iPod Touch 1G & 2G to go away and use your competitors products!

The irony is that it is those devices that made Instagram popular in the first place. :-(

(http://vaiofseries.com/whited00r/Instagram_v_2_5_0_Not_Able_to_Loggin_Report_an_Instagram_Bug_iPhone_3G_PierreP.png)


Subscribe to this thread (Notify) as we will keep it up-to-date with any new developments about our protest campaign to make Instagram backtrack and enable logging in our accounts our older Apple iPhone & iPod Touch devices again.

********************************************

Text below is outdated because Instagram is now blocking our devices with their Server-side checks so those Instagram apps are not working and you cannot Login into your Instagram account anymore! :'(

Confirmed: the Instagram v2.5.0 that lucky Whited00r 6 users can download via the built-in App Time Machine Store access is working  fine on my iPhone 3G Whited00r 6 based on iOS 3.1.3. Instagram v2.5.1 is working also on iOS 4.2.1 and 4.0 & 4.1.

If you have already an activated Instagram account, just login & Bingo!

(http://vaiofseries.com/whited00r/Instagram_v2_5_0_Sign_Up_Error_Your_Version_is_Out_of_Date_PierreP.jpg)

If you do not have an account already, trying to do it with this Instagram version will return a "Your version of Instagram is out of date. Please upgrade your app in the App Store to sign up for Instagram." error. But it is a catch 22 because the current version in iTunes is not compatible. Workaround:

Edit 2013-03-20: You can now use the Google Chrome browser on your computer and the Instagram for Chrome extension linked above to Sign Up and register a new Instagram account or log in your existing one.  ;)

1- Use somebody else newer iPhone or Android phone to create an account, log out and then login on your older iPhone 2G 3G or iPod Touch 2G 3G.

2- If you cannot do that, my crazy workaround because you can only register and create an account using a iOS or Android device normally:

Download the virtual Android app player that works on Windows or Mac: http://www.bluestacks.com/ (http://www.bluestacks.com/)

Register, download apps with it and use any Android apps including Instagram to create an account. Then login on your older device.  ;)

So I used Microsoft's Windows to run Google's Android to workaround my Apple iOS problem.  ;D ;D ;D

*****

For those not running Whited00r 6 so not having it's exclusive App Time Machine custom download app, you can download this tested and confirmed Instagram v2.5.0 working on iOS 3.1.3, 4.0, 4.1 and iOS 4.2.1 here: http://limelinx.com/dqsrs (http://limelinx.com/dqsrs) mirror: http://www.sendspace.com/file/d7xp7v (http://www.sendspace.com/file/d7xp7v)

Note: you can try this cracked & working Instagram v2.5.1 but it requires IOS 4+ (http://www.sendspace.com/file/9ao0ky)(4.0, 4.1, 4.2.1) and I tried a couple of versions of v2.5.1 and it will not install on Whited00r 6 based on the faster & more fluid iOS 3.1.3. Edit 2013-03-21: Instagram is blocking also the Instagram v2.5.1 app which requires iOS 4 and above!

You can install the Instagram v2.5.0 or v2.5.1 .ipa to the iPhone or iPod Touch using these great iTunes alternatives free iTools (http://www.whited00r.com/forum/index.php?topic=6899.msg67222#msg67222) (my favorite tool, versions for Mac or PC) or iFunBox (http://www.i-funbox.com/).

(http://www.whited00r.com/forum/index.php?action=dlattach;topic=6971.0;attach=895;image)

*****

Instagram v2.5.0 Flicker Crashing

...But when I configurate flickr acount, instagram crashed... only in flickr acount. Is it possible?

I can confirm that Instagram v2.5.0 crashes when trying to link it to my Flicker account.

The reason is that Instagram is now blocking Flickr on that version.

Flickr Crashing Instagram Workaround:

1- Go here to get a Flickr Uploading by Email address: http://www.flickr.com/account/uploadbyemail/ (http://www.flickr.com/account/uploadbyemail/)

2- Add that email to your contacts. You could name the contact Flickr Upload for example.

3- Take photo(s) with Instagram and filter to taste.

4- Don't waste your time trying to share the photo via Flickr Upload email using Instagram as it does not work. It will not show in your Photostream.

5- Go to your Camera Roll and open your Instagram made photo and send by email to Flickr Upload. The Subject line of the email will be your photo's name in the Photostream.

Et voilà!  :D

*****

Instagram Basics http://help.instagram.com/customer/portal/topics/43525-instagram-basics (http://help.instagram.com/customer/portal/topics/43525-instagram-basics)

bcooper moderator edit: How to access instagram on your PC
A lovely tutorial was made by cpa12paulo that tells you how to access and upload photos to instagram from your computer, until this problem has been resolved :)
Temporary fix to Instagram Usage :D (http://www.whited00r.com/forum/index.php/topic,8171.0.html)
Title: Re: [Solved] whited00r 6 Working Instagram - Crashing w/ Flickr
Post by: enalgre on December 17, 2012, 01:42:08 AM
This is GOOD awesome !!
Title: [Solved] whited00r 6 Working Instagram - Workaround Flickr Crashing - IOS 3.1.3
Post by: PierreP on December 17, 2012, 10:48:22 PM
And now, with little hope I ask again, can you find path2.0 & line messenger crack version for our WD6 heheheh :D :D

1- Sorry, I have zero interest in those apps.  :'(

2- This is not an app request thread, it's an Instagram thread.  :o so please stay on topic as that's a whited00r Forum Rule.  :-\ We don't want this forum to turn into an unusable free-for-all bordello like Facebook.  :o

3- For app requests or to share links to external sites where you found some compatible apps  8) go here: Apps Compatible with iOS 3.1, 3.1.3, 4.1 & 4.2.1 (http://www.whited00r.com/forum/index.php/board,99.0.html)

I figured out a Flickr Crashing Instagram Workaround and updated post #1.  :)
Title: Re: [Solved] whited00r 6 Working Instagram - Workaround Flickr Crashing - IOS 3.1.3
Post by: enalgre on December 18, 2012, 01:52:01 AM
And now, with little hope I ask again, can you find path2.0 & line messenger crack version for our WD6 heheheh :D :D

1- Sorry, I have zero interest in those apps.  :'(

2- This is not an app request thread, it's an Instagram thread in a Troubleshooting Forum.  :o so please stay on topic as that's a whited00r Forum Rule.  :-\ We don't want this forum to turn into an unusable free-for-all bordello like Facebook.  :o

3- Try the Amateur Developers (http://www.whited00r.com/forum/index.php?board=78.0) or the Spambucket (http://www.whited00r.com/forum/index.php?board=20.0) Forums.

I figured out a Flickr Crashing Instagram Workaround and updated post #1.
1. Oh no problem pierrep, you still a good man!!
2. Hehee i'm sorry :D :D
3. Yes instagram is enough for me no need a flickr..thank you pierrep :* no homo
Title: Re: [Solved] whited00r 6 Working Instagram - Workaround Flickr Crashing - IOS 3.1.3
Post by: dude22072 on February 04, 2013, 12:02:49 AM
I try to signup but it says i cant because its an outdated app.
is their any work around for this?
Title: Re: I try to signup but it says i cant because its an outdated app
Post by: PierreP on February 04, 2013, 06:24:34 AM
I try to signup but it says i cant because its an outdated app.
is their any work around for this?

App name? Version? Where did you downloaded it from? Device model? iOS version if not whited00r (version)?  :o
Title: Re: [Solved] whited00r 6 Working Instagram - Workaround Flickr Crashing - IOS 3.1.3
Post by: kevinek2 on February 04, 2013, 08:32:11 AM
I try to signup but it says i cant because its an outdated app.
is their any work around for this?

me too, if i try to sign up it says that it is outdated  :-[
Title: Re: [Solved] whited00r 6 Working Instagram - Workaround Flickr Crashing - IOS 3.1.3
Post by: PierreP on February 04, 2013, 10:05:06 AM
I try to signup but it says i cant because its an outdated app.
is their any work around for this?

me too, if i try to sign up it says that it is outdated  :-[

App name? Version? Where did you downloaded it from? Device model? iOS version if not whited00r (version)?

See post #1 in this thread about a fix for the "Your version of Instagram is out of date. Please upgrade your app in the App Store to sign up for Instagram." error.
Title: Re: [Solved] whited00r 6 Working Instagram - Workaround Flickr Crashing - IOS 3.1.3
Post by: kevinek2 on February 04, 2013, 01:19:14 PM
I try to signup but it says i cant because its an outdated app.
is their any work around for this?

me too, if i try to sign up it says that it is outdated  :-[

App name? Version? Where did you downloaded it from? Device model? iOS version if not whited00r (version)?

See post #1 in this thread about a fix for the "Your version of Instagram is out of date. Please upgrade your app in the App Store to sign up for Instagram." error.

im gonna try your workarround boss PierreP

hehehe still downloading
Title: Re: [Solved] whited00r 6 Working Instagram - Workaround Flickr Crashing - IOS 3.1.3
Post by: PierreP on February 04, 2013, 01:30:15 PM
I try to signup but it says i cant because its an outdated app.
is their any work around for this?

me too, if i try to sign up it says that it is outdated  :-[

App name? Version? Where did you downloaded it from? Device model? iOS version if not whited00r (version)?

See post #1 in this thread about a fix for the "Your version of Instagram is out of date. Please upgrade your app in the App Store to sign up for Instagram." error.

im gonna try your workarround boss PierreP

hehehe still downloading

And Welcome to the whited00r forum!  8)

A must read for all new whited00r users is the sticky (it means an important thread pinned at the top of the forum list) Whited00r 6 - FAQ & Troubleshooting - READ BEFORE POSTING! (http://www.whited00r.com/forum/index.php?topic=7258.0) with answers to many questions you might have.

I still would like to know this for the benefit of other whited00r users with the same issue: App name? Version? Where did you downloaded it from? Device model? iOS version if not whited00r (version)? As per this also must read IMO: WD 6: Tips to Quickly Solve your Problems/Bugs & Get Answers FAST! (http://www.whited00r.com/forum/index.php?topic=6934.0)

And thank you in advance for reporting back in this thread.  8)
Title: Re: [Solved] whited00r 6 Working Instagram out of Date - Flickr Crashing iOS 3.1.3
Post by: kevinek2 on February 04, 2013, 02:22:22 PM
i downloaded instagram from your links, and my my device is iphone 3G iOS 4.2.1 im sorry but im very new to the iOS family :)
Title: Re: [Solved] whited00r 6 Working Instagram out of Date - Flickr Crashing iOS 3.1.3
Post by: PierreP on February 04, 2013, 02:34:04 PM
i downloaded instagram from your links, and my my device is iphone 3G iOS 4.2.1 im sorry but im very new to the iOS family :)

Play with the dog-slow 4.2.1 for a couple of hours then try WD 6 & see the light. Read the FAQ linked above.

You did not say if you got Instagram working or not.
Title: Re: I try to signup but it says i cant because its an outdated app
Post by: dude22072 on February 04, 2013, 11:46:00 PM
I try to signup but it says i cant because its an outdated app.
is their any work around for this?

App name? Version? Where did you downloaded it from? Device model? iOS version if not whited00r (version)?  :o
Instagram 2.5.0; link in 1st post; iPod touch 1st gen; 3.1.3 whited00r 6
Title: Re: Instagram I try to signup but it says I cant because its an outdated app
Post by: PierreP on February 05, 2013, 08:47:48 AM
App name? Version? Where did you downloaded it from? Device model? iOS version if not whited00r (version)?  :o

Instagram 2.5.0; link in 1st post; iPod touch 1st gen; 3.1.3 whited00r 6

Thank you for the essential info.  8 In fact we need that info all the time on the whited00r forum because there are so many variables and an issue with iPhone 2G or 3G or iPod Touch xyx with iOS 3.1.3,, 4.1 or 4.2.1 may have different causes, troubleshooting steps or fixes and workarounds.  :o

So, did you try the Instagram Register New Account workarounds in the updated post #1?

If so, which one did you try and did it worked for you?

And noticed that a tested (by me too on iPhone 3G) working Instagram 2.5.0 can be easily found & downloaded directly from the iPhone using the App Time Machine Store?
Title: Re: Instagram I try to signup but it says I cant because its an outdated app
Post by: dude22072 on February 06, 2013, 01:22:53 AM
App name? Version? Where did you downloaded it from? Device model? iOS version if not whited00r (version)?  :o

Instagram 2.5.0; link in 1st post; iPod touch 1st gen; 3.1.3 whited00r 6

Thank you for the essential info.  8 In fact we need that info all the time on the whited00r forum because there are so many variables and an issue with iPhone 2G or 3G or iPod Touch xyx with iOS 3.1.3,, 4.1 or 4.2.1 may have different causes, troubleshooting steps or fixes and workarounds.  :o

So, did you try the Instagram Register New Account workarounds in the updated post #1?

If so, which one did you try and did it worked for you?

And noticed that a tested (by me too on iPhone 3G) working Instagram 2.5.0 can be easily found & downloaded directly from the iPhone using the App Time Machine Store?

I used the Bluestacks workaround and it was successful.  :)
Title: Re: [Solved] whited00r 6 Working Instagram out of Date - Flickr Crashing iOS 3.1.3
Post by: JustinCase on February 07, 2013, 03:09:52 AM
I need this on my iPod 1G...
Does it lag at all?
Title: [Broken!] Your version of Instagram is out of date Error
Post by: DevNic on March 19, 2013, 02:07:21 PM
Instagram is not working now.  :(
Title: Re: [Broken!] Your version of Instagram is out of date Error
Post by: PierreP on March 19, 2013, 08:55:46 PM
Instagram is not working now.  :(

You are right!

Instagram broke it with their Server-side checks.  >:(

I updated post #1 of this thread as well as the title and will keep it up-to-date. Please join in the protest and contribute to solving the Instagram for older Apple devices problem.  8)

[Broken!] Your version of Instagram is out of date Error - iOS 3.1.3 Whited00r 6 (http://www.whited00r.com/forum/index.php/topic,6992.0.html)
Title: Re: [Broken!] Your version of Instagram is out of date Error - iOS 3.1.3 Whited00r 6
Post by: Slim_Wiz on March 20, 2013, 01:08:21 PM
What about the V2.5.0 on 2.4.1 does that still work. Last time i tried that the app just would crash as soon as you opened it.
Title: Re: [Broken!] Your version of Instagram is out of date Error - iOS 2.4.1?
Post by: PierreP on March 20, 2013, 09:46:14 PM
what about the V2.5.0 on 2.4.1 does that still work. last time i tried that the app just would crash as soon as you opened it

Well read post #1 in this thread (http://www.whited00r.com/forum/index.php/topic,6992.0.html), Instagram V2.5.0 was working fine on my iPhone 3G running Whited00r 6 which is based on a custom tweaked and optimized iOS 3.1.3 and suddenly the Instagram servers are refusing to let me login into my account.  >:(

"... last time i tried that the app just would crash as soon as you opened it" - That usually happens when an app is not properly cracked and still tied to somebody else's iTunes account. There is a link to a working & tested by me Instagram V2.5.0 cracked that will not crash on starting it in post #1 (scroll down to the For those not running WD 6... chapter for the download link) as I will keep it up-to-date about the Instagram not working issue when trying to Register a new Instagram account or logging in your existing one.

What do you mean by "...on 2.4.1"? Are you saying that you are still running the extremely old iOS 2.2.1 or the dog-slow iOS 4.2.1 that I had on my iPhone 3G before?  :o

If so OMG!  ;) You should read those and will not believe all the features & speed of Whited00r 6:

[Tutorial] Backup Apps & Data BEFORE Upgrading iOS Firmware WD 6 3.1.3 4.1 4.2.1 (http://www.whited00r.com/forum/index.php/topic,7731.0.html)

Whited00r 6 - FAQ & Troubleshooting - READ BEFORE POSTING! (http://www.whited00r.com/forum/index.php?topic=7258.0)
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: Slim_Wiz on March 20, 2013, 10:58:54 PM
I ment, is instagram 2.5.0 only for 4.2.1 only. i made a typo mistake. I am a whitedoor user, it is much faster. So basically every single out of date instagram will not work and there is no way around it.



Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: PierreP on March 20, 2013, 11:26:05 PM
I ment, is instagram 2.5.0 only for 4.2.1 only. i made a typo mistake. I am a whitedoor user, it is much faster. So basically every single out of date instagram will not work and there is no way around it.

Instagram v2.5.0 works on WD 6 and any iOS 3.1.2 and above. See post #1.

"...there is no way around it" - Not if Instagram - Facebook is blocking us from logging into our accounts on the server-side but WhatsApp did the same and they backed up partially & re-enabled logging in if your iPhone/phone number combo had previously been activated after our email & posting in their Facebook page pressure campaign.

This is why all shut out from Instagram iPhone 2G & 3G as well as iPod Touch 1G & 2G Instagram users must contribute to the protest campaign as explained how to do it in post #1.

I will add other ways to protest tomorrow or later today but the first step is to file Bug reports to Instagram's "support".
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: Slim_Wiz on March 20, 2013, 11:33:19 PM
alright cheers mate
Title: Your version of Instagram is out of date Error Not Working v2.5.1 iOS 4.2.1, 4.1
Post by: PierreP on March 21, 2013, 06:51:51 PM
Bad news, we just tested Instagram v2.5.1 on stock iOS 4.2.1 and Instagram - Facebook is blocking it also on their server-side.  :(

Instagram v2.5.1 is the last version not requiring iOS 4.3+ which can be installed only on iPhone 3GS or iPod Touch 3G and newer devices.

I updated post #1.
Title: Instagram from a backup Working
Post by: Rashid on March 22, 2013, 03:25:59 PM
I hate these people! -.-

I can install Instagram from a backup made with iTools and I am already logged in, but what should people do who never had Instagram before ?! -.-

Apple is the world meanest company!
Title: Re: Instagram from a backup Working?
Post by: PierreP on March 22, 2013, 06:46:35 PM
I hate these people! -.-
I can install Instagram from a backup made with iTools and I am already logged in, but what should people do who never had Instagram before ?! -.-

Apple is the world meanest company!

Thank you for the info and contributing to the Whited00r community so +1 Internets for you.  8)

Could you explain in details step-by-step what you did including app & iOS versions and device model please?

This could help many users.  8)


*****


A must read before installing any firmware on your iPhone or iPod Touch: [Tutorial] Backup Apps & Data BEFORE Upgrading iOS Firmware WD 6 3.1.3 4.1 4.2.1 (http://www.whited00r.com/forum/index.php/topic,7731.0.html)
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4
Post by: Yoooedwin on March 23, 2013, 05:59:37 AM
Any updates on a fix? I recently made one:/
Title: Re: Instagram from a backup Working?
Post by: Rashid on March 23, 2013, 09:54:07 PM
On my iPhone I am already logged in, but on my iPod I am not, although it's the same Instagram app backup made with iTools. :(

iPhone 2G Whited00r 6 (works), I don't know why but it's not working on my iPod Touch 2G iOS 4.2.1 jailbroken.
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4
Post by: Yoooedwin on March 23, 2013, 10:07:12 PM
How did you login in on your iPhone? I'm on a 2G but I can't?

Edit: I read what you meant Rashid.

This is from the Instagram  website:

Quote
Instagram v2.0 and later versions are supported on iOS 4.2.1 and above. If you are not running this version of iOS or later on one of the devices listed below, you will continue to see the old version of Instagram (which does not include the Lux feature or new filters such as Sierra).

You can find your iOS version by opening the Settings app on your device, then tapping General > About.

Supported devices include:

iPhone 5

iPhone 4S

iPhone 4

iPhone 3GS

iPod Touch (3rd and 4th generations)

iPad 3

iPad 2

iPad

It doesn't seem like they care about us.  :-\
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: enalgre on March 24, 2013, 02:12:17 AM
I also have already logged in on instagram my iphone 3g wd6..
so, we need public protest campaign right ??
i'ill protest here now https://www.facebook.com/help/contact/?id=364531043625021 :o
Title: Re: Your version of Instagram is out of date Error After Logging Out!
Post by: cpa12paulo on March 24, 2013, 10:48:11 AM
Hi. I'm running stock iOs 4.2.1 on my iPhone 3g and I have an Instagram v3.0.0 from my backup :( Sad to say but I'm also experiencing this too... I'm pissed off because It's fully functional this morning. LOL but I guess I did a huge mistake on logging my account out :( I'm gonna make a complain as soon as I sit on my PC. :(
Title: Instagram v3.0.0 Your version of Instagram is out of date Error - Logging Out
Post by: PierreP on March 24, 2013, 06:49:43 PM
Hi. I'm running stock iOS 4.2.1 on my iPhone 3g and I have an Instagram v3.0.0 from my backup :( Sad to say but I'm also experiencing this too... I'm pissed off because It's fully functional this morning. LOL but I guess I did a huge mistake on logging my account out :( I'm gonna make a complain as soon as I sit on my PC. :(

"...stock iOS 4.2.1 on my iPhone 3g... Instagram v3.0.0... It's fully functional this morning. LOL but I guess I did a huge mistake on logging my account out" - An other proof that those Instagram v2.5.0, v2.5.1 and v3.0.0 apps are working fine and that it is Instagram - Facebook on their server-side that are blocking our devices. Really disgusting IMO.

I don't mind Instagram pushing a new app version with new features for newer devices but I find unacceptable that it is not compatible with first gen & second gen iPhone & iPod Touch which from an engineering point of view is very easy to do.

It would be also very easy for Apple/iTunes to require to be admitted in iTunes that all app updates include backward compatibility for iOS 3.1.3 or 4.1+ except for new apps & games that require faster CPU & GPU naturally.

Or Apple could simply keep in iTunes the last version compatible with iOS 4.2.1 and add the new ones requiring iOS 4.3 and later. But that would be for a company that care about the people who bought their older devices instead of pushing them to buy new ones.  :-\

Apple/iTunes could also add very easily a simple filter by iOS compatibility in iTunes but then we would not be coaxed to throw in the garbage perfectly working devices and buy new ones because of the nagging "Requires iOS 4.3 or later".

See my workaround for that lack of iOS filter using their competitor Google here: How-To Find iOS 3.1.3 4.1 4.2.1 Compatible Apps + iTunes Filter (http://www.whited00r.com/forum/index.php/topic,7108.0.html)  ;) A proof that iTunes could also do it easily.

Read more about Apple's Planned Obsolescence (https://www.google.com/search?&q=apple+Planned+Obsolescence) marketing strategy.


*****


That is why I joined the Whited00r team a few months ago because THEY DO support our older devices and they were not the ones who made money with them in the first place.  8)


BTW we are looking for volunteers to join our Moderator Team as several of us are too busy working on updating the main site, making forum better and also working on an awesome Whited00r 6.1 update. Just PM me or other Admin's if you would like to apply and that includes if your language is different from English as we would like to add support for people like you in your own language.  :)
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: m1namoto on March 26, 2013, 04:29:29 PM
3 days ago, changed the password via the web interface...now I understand that made ​​a big mistake  :D

already managed to warn the Russian community with old Apple devices of the incident, that in no case log out...gave a link to this topic, showing how to report for support...
wrote a petition to support and write in the appstore
P.S. sorry for my English...from Ukraine with love  :D



Title: iPhone 3G Logged in Instagram but Cannot Upload Photos
Post by: afroulitsa on April 03, 2013, 05:22:18 PM
I have a iPhone 3G, didnt log out from my account, but as i tried to upload today a foto i came accross the same message!!

Last week i did upload some fotos, today i cannot!  :(




PierreP Moderator note: Edited the post's title to add relevant keywords as described in Whited00r 6: Tips to Quickly Solve your Problems/Bugs & Get Answers FAST! (http://www.whited00r.com/forum/index.php?topic=6934.0) and fixed a few typos.
Title: Re: iPhone 3G Logged in Instagram but Cannot Upload Photos
Post by: PierreP on April 03, 2013, 09:51:32 PM
I have a iPhone 3G, didnt log out from my account, but as i tried to upload today a foto i came accross the same message!!

Last week i did upload some fotos, today i cannot!  :(

Thank you afroulitsa for reporting back as it will help other Whited00r users with the same Instagram problem.  8)  So +1 Internets for you for giving back to the WD community.

So you are logged in your Instagram account on your iPhone 3G and can surf the site including your photos but cannot upload any new ones, right?

Could you tell us which iOS version you are running if not Whited00r and also the Instagram version you are using?
Title: Re: iPhone 3G Logged in Instagram but Cannot Upload Photos
Post by: m1namoto on April 03, 2013, 10:05:18 PM
So you are logged in your Instagram account on your iPhone 3G and can surf the site including your photos but cannot upload any new ones, right?
Could you tell us which iOS version you are running if not Whited00r and also the Instagram version you are using?
no...he wrote, what he stay in system autorized (not log out) :)
i'am every day trying install 2.5.0\2.5.1\3.0.0 versions, and trying logginin'....but...
i have alternative instagram viewer "instagallery", but this program work on iOS 4+ only...
i can upload ipa, if you wish...maybe you deodexed ipa and change iOS priority, or change info in SystemVersion on your iDevice, to iTools not lock installation ipa...
P.S. sorry 4 ma English :)
Title: Re: iPhone 3G Instagram Versions & Alternative Viewer
Post by: PierreP on April 03, 2013, 10:48:48 PM
no...he wrote, what he stay in system autorized (not log out) :)
i'am every day trying install 2.5.0\2.5.1\3.0.0 versions, and trying logginin'....but...
i have alternative instagram viewer "instagallery", but this program work on iOS 4+ only...
i can upload ipa, if you wish...maybe you deodexed ipa and change iOS priority, or change info in SystemVersion on your iDevice, to iTools not lock installation ipa...
P.S. sorry 4 ma English :)

"no...he wrote, what he stay in system autorized (not log out)..." - It is the same meaning as being logged in your Instagram account.  ;)

"...i'am every day trying install 2.5.0\2.5.1\3.0.0 versions" - Don't waste your time, ALL of the Instagram versions compatible with iOS 3.1.2, 3.1.3, 4.1 & iOS 4.2.1 are blocked by Instagram on their server-side: Instagram 1.94, 2.0.5, 2.2.1, 2.4.0, 2.5.0, 2.5.1 and 3.0.

...alternative instagram viewer "instagallery", but this program work on iOS 4+ only - Could you tell us the specific version number you are using? The oldest version of Instagallery v1.0 requires iOS 4.1 + and the current Instagallery 1.4.9 in iTune$ (https://itunes.apple.com/us/app/instagallery-browse-instagram/id422065992?mt=8) "Requires iOS 4.3 or later".  :-\

...i can upload ipa, if you wish - You cannot attach an app to a post per Whited00r's forum rules but you can start a new thread in the Apps Compatible with iOS 3.1, 3.1.3, 4.1 & 4.2.1 (http://www.whited00r.com/forum/index.php/board,99.0.html) forum and share a link to the app that you could upload to your Rapidshare or slingfiles or Sendspace or whatever account you have or share a link to an already uploaded by somebody else app.

*****

Posting Tips

...sorry 4 ma English - No worries, we always appreciate people making the effort to post and help the Whited00r community which is more important than proper grammar IMO.  ;)

English is not my native language so I use the spellchecker with English dictionary enabled in Firefox & Chrome and learn from the mistakes it shows. An other trick is to write your post in Words, select the English language in the page language settings in the bottom and do a Spelling & Grammar Review. That's what I do when posting in the Whited00r Soporte en Español (http://www.whited00r.com/forum/index.php/board,97.0.html) board because I can speak it fluently but am not very good at writing it.  :-\
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: afroulitsa on April 04, 2013, 04:36:51 AM
the version that i am using is WD 6, (3.1.3) and instagram that i have downloaded from the TimeMachine ApplMarket. From thr very first moment that i 've used it since WD 6, i couldnt delete any foto that i  have uploaded and i became everytime i tried the following message: please update ios version to delete fotos.. or something like that! Hope i helped! :)
Title: Re: iPhone 3G Instagram Versions & Alternative Viewer
Post by: m1namoto on April 04, 2013, 09:57:38 AM
"...i'am every day trying install 2.5.0\2.5.1\3.0.0 versions" - Don't waste your time, ALL of the Instagram versions compatible with iOS 3.1.2, 3.1.3, 4.1 & iOS 4.2.1 are blocked by Instagram on their server-side: Instagram 1.94, 2.0.5, 2.2.1, 2.4.0, 2.5.0, 2.5.1 and 3.0.
ok, thanks
...alternative instagram viewer "instagallery", but this program work on iOS 4+ only - Could you tell us the specific version number you are using? The oldest version of Instagallery v1.0 requires iOS 4.1 + and the current Instagallery 1.4.9 in iTune$ (https://itunes.apple.com/us/app/instagallery-browse-instagram/id422065992?mt=8) "Requires iOS 4.3 or later".  :-\
i download instagallery from vShare server http://enapp.appvv.com/ (http://enapp.appvv.com/)(chinese appmarket...with ugly requests, lugs and speed)...this server have ipa history versions...from old to new versions...vshare have an instagallery 1.2.4 version only
but now i back 2 stock iOS 4.2.1 (+ greenpois0n jailbreak) on my iPod Touch 2G, and install this app without problem
...i can upload ipa, if you wish - You cannot attach an app to a post per Whited00r's forum rules but you can start a new thread in the Apps Compatible with iOS 3.1, 3.1.3, 4.1 & 4.2.1 (http://www.whited00r.com/forum/index.php/board,99.0.html) forum and share a link to the app that you could upload to your Rapidshare or slingfiles or Sendspace or whatever account you have or share a link to an already uploaded by somebody else app.
i know :)
ok...i upload instagallery to my dropbox from my iPod :) http://dl.dropbox.com/u/51013566/Instagallery%201.2.4.ipa (http://dl.dropbox.com/u/51013566/Instagallery%201.2.4.ipa)
Title: Re: Instagallery 1.2.4 iOS 4.1 compatible
Post by: PierreP on April 04, 2013, 01:40:32 PM
...ok...i upload instagallery to my dropbox from my iPod :) http://dl.dropbox.com/u/51013566/Instagallery%201.2.4.ipa (http://dl.dropbox.com/u/51013566/Instagallery%201.2.4.ipa)

Thanks!

Suggestions for apps naming:

1- Never leave blank spaces as they show as "%20" and can break links: Instagallery%201.2.4.ipa

2- Include the minimum iOS required to run it like so for example: Instagallery_1.2.4_iOS41.ipa

If you don't know the minimum iOS requirements, you can use the free & powerful iPhone browser/manager iTools (http://itools.hk/en_index.htm) (click English top right of the page, both Windows & Mac versions are available, iTunes 10.6 or newer needs to be installed on your computer and turned off for better results).

iTools for Windows > Settings > Local Resource > Add your custom app folder then > Library > Applications > Management an you can see the Instagallery v1.2.4 app info in the image below.

(http://vaiofseries.com/whited00r/iTools_Apps_iOS_PierreP.jpg)


Note: I don't have a Mac so I don't know if the iTools for Mac version has the same features.  :o
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: MikaGG on April 04, 2013, 07:05:57 PM
my instagram its not working still, i downloaded the new cracked version it gives me again "This  is outdated please upgrade your app in the app store to log in to instagram".... help
Title: iPod Touch 1G Logged in Instagram but Cannot Upload Photos
Post by: aTastyRabbit on April 05, 2013, 01:48:46 AM
I don''t have problem with the login it doesn't allow me to upload picture to instagram on my iPod Touch 1G.




PierreP Moderator note: Edited post title to add relevant keywords as described in Whited00r 6: Tips to Quickly Solve your Problems/Bugs & Get Answers FAST! (http://www.whited00r.com/forum/index.php?topic=6934.0)
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: PierreP on April 05, 2013, 03:40:34 AM
(http://)
my instagram its not working still, i downloaded the new cracked version it gives me again "This  is outdated please upgrade your app in the app store to log in to instagram".... help

Welcome to the Whited00r forum!  8)

Read post #1 in this thread  which is always kept up-to-date by the Whited00r team about the Instagram "outdated please upgrade your app" problem.  ;)

And help yourself and the community too by bugging Instagram's "Support" as described in the post.  8)
Title: iPhone 3G & iPod Touch 1G - Logged in Instagram but Cannot Upload Photos!
Post by: PierreP on April 05, 2013, 04:12:29 AM
I don''t have problem with the login it doesn't allow me to upload picture to instagram on iPod Touch 1G.

So you have the exact same problem on your iPod Touch 1G as described by afroulitsa above on his iPhone 3G: the Instagram server-side broke the backward compatibility and does not understand anymore the upload and delete photos instructions code made by older versions of the Instagram app for users who are already logged in into their accounts.

That would be very easy to fix by the Instagram engineers if they would really care about their users.  :-\

Did you create an Instagram support ticket about that?  ??? It is the only way to solve this problem as we cannot hack into Instagram/Facebook's servers.  :o

I have a iPhone 3G, didnt log out from my account, but as i tried to upload today a foto i came accross the same message!!

Last week i did upload some fotos, today i cannot!  :(
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: Auguste99 on April 13, 2013, 06:15:11 PM
The problem came up with me, too. I can't even log in and use it as usual.
My iPhone is 3G, iOS 4.1, not installed Whited00r 'cause WD has not been common as of now in my country.

I've tried to install confirmed & tested Instagram v2.5.1, even v2.5.0 as above those lines in post #1 but the fkn message still came up.

Please help me with compatible version without any crash and prevention, Instagram is my main sources of my business !
Title: Re: Instagram is Not Working & Whited00r in Vietnam
Post by: PierreP on April 13, 2013, 09:04:16 PM
The problem came up with me, too. I can't even log in and use it as usual.
My iPhone is 3G, iOS 4.1, not installed Whited00r 'cause WD has not been common as of now in my country.

I've tried to install confirmed & tested Instagram v2.5.1, even v2.5.0 as above those lines in post #1 but the fkn message still came up.

Please help me with compatible version without any crash and prevention, Instagram is my main sources of my business!

Welcome to the Whited00r forum!  8)

Sorry but your problem like all of us is not the Instagram app version. The problem is that the Instagram servers are blocking older iPhone & iPod Touch. Read post #1 of this thread (http://www.whited00r.com/forum/index.php/topic,6992.0.html) which is always kept up-to-date if we find a solution.

"Instagram is my main sources of my business!" - If you absolutely need Instagram on your iPhone then you need to buy an iPhone 3GS which can run iOS 4.3 or newer. Sorry!   :'(  Say thank you to Instagram/Facebook & Apple for that.  :-\

*****

"...not installed Whited00r 'cause WD has not been common as of now in my country [Vietnam]" - Well Whited00r 6 is available since 2012-12-12 and these are our statistics for downloads made by users in Vietnam:

Whited00r 6 Unlocked version iPhone 3G: 6,392

Whited00r 6 Normal (locked) version iPhone 3G: 3,724

Whited00r 6 Unlocked version iPhone 2G: 2,636

Whited00r 6 Normal (locked) version iPhone 2G: 1,220

Whited00r 6 iPod Touch 2G: 716

Whited00r 6 iPod Touch 1G: 334

For a grand total of 15,870 downloads so far.  ;)
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: lostreaper on April 30, 2013, 10:52:15 AM
First Whatsapp now Instagram.. I should have got it when it warns me to update the app in order to delete a photo last month...
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: noxirose on May 05, 2013, 01:37:46 PM
Dear Support,
I downloaded Bluestacks, and installed Instagram on that-->  create an account.
Then login on my Iphone 3G WD6, but still received a notice:  Your version of Instagram is out of date
Pls help me. :-X

Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: Bruan on May 05, 2013, 01:48:32 PM
Dear Support,
I downloaded Bluestacks, and installed Instagram on that-->  create an account.
Then login on my Iphone 3G WD6, but still received a notice:  Your version of Instagram is out of date
Pls help me. :-X

Welcome to the forums :)

That's because you were not logging in on the device, you were logging in on something else ;)  You would have needed the (most likely incompatible) backup data from the Bluestacks thing to be put on the device.  I have no clue how one would do that, and I don't think the backup data is transferable from android to iOS. :(
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: noxirose on May 06, 2013, 03:16:09 PM
Welcome to the forums :)

That's because you were not logging in on the device, you were logging in on something else ;)  You would have needed the (most likely incompatible) backup data from the Bluestacks thing to be put on the device.  I have no clue how one would do that, and I don't think the backup data is transferable from android to iOS. :(
So How do have to solve thís problem?
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: Bruan on May 06, 2013, 04:21:53 PM
You can't ;)   There is no way to transfer data from android to iOS in terms of app backups.   At least not that I know of anyway, I don't have any clue as to where application data is saved on android, or even the layout of android.
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: ta_nel on May 06, 2013, 05:20:27 PM
The problem came up with me, too. I can't even log in and use it as usual.
My iPhone is 3G, iOS 4.1, not installed Whited00r 'cause WD has not been common as of now in my country.

I've tried to install confirmed & tested Instagram v2.5.1, even v2.5.0 as above those lines in post #1 but the fkn message still came up.

Please help me with compatible version without any crash and prevention, Instagram is my main sources of my business !
Hi! Right now everybody wants a fix for this problem, so you should just stay tuned to the further posts of this topic and hit that "Notify" button.  :)
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: cpa12paulo on May 07, 2013, 01:38:16 PM
Guys Check this out. HAHAHAHAHAHA >>>> https://itunes.apple.com/us/app/instagram/id389801252?mt=8

I LOLed at this XD now, instagram requires iOS 5.0 XDD HAHAHAHAHAHA T.T

I don't know what to say O.o Instagram is becoming so much annoying right now -____- LOL
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: m1namoto on May 07, 2013, 03:01:46 PM
Guys Check this out. HAHAHAHAHAHA >>>> https://itunes.apple.com/us/app/instagram/id389801252?mt=8

I LOLed at this XD now, instagram requires iOS 5.0 XDD HAHAHAHAHAHA T.T

I don't know what to say O.o Instagram is becoming so much annoying right now -____- LOL
Lol...maybe in the future whited00r community receive many users with the same problem with instagram. I solved this problem, I buy china smartphone with android, it cost 43$ XD
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: cpa12paulo on May 08, 2013, 12:44:19 AM
Lol...maybe in the future whited00r community receive many users with the same problem with instagram. I solved this problem, I buy china smartphone with android, it cost 43$ XD

For Pete's sake. LOL Someday I will buy the cheapest android in the market, and I'll use it just for that selfish instagram app. HAHAHAHA XD If only I went to the summer job my friends were talking about last month -___- HAHAHA

I want to install bluestacks but I have problems installing it :(( Too bad for me. LOL
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: forest on May 08, 2013, 04:50:49 PM
I wish there would be a trick to fix this? Maybe faking the version or use modification to the part about server login etc idk much about it but i wish I could use instagram on my old iPhone before I get iPod touch 5g.
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: PierreP on May 08, 2013, 05:42:18 PM
I wish there would be a trick to fix this? Maybe faking the version or use modification to the part about server login etc...

This entire thread is about trying to fix this and we ALL wish there was a way to do it.  ;)

Sorry, your suggestions have been tried and they do not work.

As pointed out above by cpa12paulo in iTunes currently it is Instagram version 3.5.1 (https://itunes.apple.com/us/app/instagram/id389801252?mt=8) and it "Requires iOS 5.0 or later" so that means they now also dropped support for iOS 4.3.

If the Instagram servers besides checking your app version are also doing conditional checks for the iOS version running on your iPhone and are using code that only newer devices with the newer ARMv7 CPU understands but not the ARMv6 CPU found in older 1st & 2nd generation iPhone 2G/3G & iPod Touch 1G/2G then it will never be fixed.  :'(

So move on to an other app or buy a newer phone which is exactly what Apple & Instagram wants you to do.  :-\

*****

Thank you for the pointer cpa12paulo so +1 Internets for you for giving back to the Whited00r community.  8)

I updated post #1 with that new iOS 5.0 requirement, including in the screen captures:  Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1 (http://www.whited00r.com/forum/index.php/topic,6992.0.html)
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: mackiw on May 12, 2013, 06:31:48 AM
Hey guys! I just installed Instagram v3.0.0 on my iPod Touch 2nd gen (running iOS 4.2.1). But when I've tried to log in, it says "Your version of Instagram is out of date. Please upgrade your app in the App Store to log in to Instagram."

Why is Instagram so selfish? Just not like to Facebook, Twitter, Viber - where I can still log in and access my account. But on Instagram, UGH...

Hope you guys can find a solution soon. Thanks! :)
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: forest on May 13, 2013, 10:12:35 AM
yes I've checked out. instagram, whatsapp are suck. i give up.
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: mackiw on May 13, 2013, 12:12:17 PM
yes I've checked out. instagram, whatsapp are suck. i give up.

Yeah. I also cant register my number to whatsapp. It always says poor wifi connection! Duhh...
Title: .
Post by: itsYoungMaine on July 07, 2013, 10:09:16 AM
.
Title: Re: Instagram
Post by: leejenshil on July 07, 2013, 12:02:37 PM
i'm checking it right know, do you have to use archytype?
Title: Re: Instagram
Post by: Bruan on July 07, 2013, 02:33:23 PM
i'm checking it right know, do you have to use archytype?

You shouldn't need to as just cleaning logs wouldn't do much O.o
Title: Re: Instagram
Post by: leejenshil on July 08, 2013, 12:33:34 PM
what part in the info.plist should i change?

there are two keys, wich one to change?

there is:
   <key>CFBundleVersion</key>
   <string>2.5.0</string>
and there is:
   <key>CFBundleShortVersionString</key>
   <string>2.5.0</string>
Title: .
Post by: itsYoungMaine on July 08, 2013, 06:47:06 PM
.
Title: Re: Instagram
Post by: leejenshil on July 08, 2013, 07:39:27 PM
same error
Title: Re: Instagram
Post by: cad111 on July 09, 2013, 03:58:08 AM
archtype makes my ipad freeze on boot ..  : /
Title: Re: Instagram
Post by: Bruan on July 09, 2013, 04:50:54 AM
archtype makes my ipad freeze on boot ..  : /

There is a fix for that mentioned many times ;)
Title: .
Post by: itsYoungMaine on July 11, 2013, 01:15:58 PM
.
Title: Re: Instagram fix
Post by: germangabrielwle on July 12, 2013, 03:09:49 AM
OMG i'm going to die, i logged out and i tried to login again and now i can't even login !!!!!!!  >:( >:( >:( >:( >:( >:( >:( >:( >:(

I H A T E YOU !!!!
Title: Re: Instagram fix
Post by: Bruan on July 12, 2013, 03:42:38 AM
OMG i'm going to die, i logged out and i tried to login again and now i can't even login !!!!!!!  >:( >:( >:( >:( >:( >:( >:( >:( >:(

I H A T E YOU !!!!

This was only for those to try who didn't have it working before :s
Title: Re: Instagram fix
Post by: germangabrielwle on July 12, 2013, 03:50:07 AM
This was only for those to try who didn't have it working before :s

but now i can't login !! i tried all :'(
Title: Re: Instagram fix
Post by: Bruan on July 12, 2013, 03:51:37 AM
but now i can't login !! i tried all :'(

Did you make a backup of the app when it was working?
Title: Re: Instagram fix
Post by: germangabrielwle on July 12, 2013, 04:05:31 AM
Did you make a backup of the app when it was working?

yess with iTools and with the backup app(in the appstore button) and first i tried to use the backup but in the app says
the dropbox link it isn't working anymore :'( so i tried to put the backup manually and nothing happend.
Title: Re: Instagram fix
Post by: Bruan on July 12, 2013, 04:19:35 AM
Use the iTools backup to restore to the data to the app :)
Title: Re: Instagram fix
Post by: germangabrielwle on July 12, 2013, 04:32:34 AM
Use the iTools backup to restore to the data to the app :)

it don't work  :'( :'( :'( :'(
Title: Re: Instagram fix
Post by: Bruan on July 12, 2013, 04:40:25 AM
it don't work  :'( :'( :'( :'(

You used the iTools backup function and didn't just manually copy files at random out of the instagram app folder?
Title: Re: Instagram fix
Post by: germangabrielwle on July 12, 2013, 04:43:48 AM
You used the iTools backup function and didn't just manually copy files at random out of the instagram app folder?

where is the backup function  :'(?
Title: Re: Instagram fix
Post by: Bruan on July 12, 2013, 05:25:00 AM
where is the backup function  :'(?

[Tutorial] Backup Apps & Data BEFORE Upgrading iOS Firmware WD 6 3.1.3 4.1 4.2.1 (http://www.whited00r.com/forum/index.php/topic,7731.0.html)

What files did you back up then using iTools?  It may be a simple fix of changing permissions of the files/folders :)
Title: Re: Instagram fix
Post by: leejenshil on July 12, 2013, 09:07:11 AM
this didn't work i'm geting the same error ( iphone 2g Wd 6 ios 3.1.3 ) i'll try again
Title: .
Post by: itsYoungMaine on July 18, 2013, 09:02:29 AM
.
Title: Re: Instagram v2.5.0 fix - info.plist Mod - Not Working
Post by: PierreP on July 24, 2013, 10:02:39 AM
How to let instagram work again on your iDevice..

STEPS:
1. Go to Blend Store (blendstore.weebly.com) PierreP moderator note: it is a cracked by Persephone Instagram+2.5.0.ipa (direct link) (http://www.mediafire.com/download/8qmhsh0zoo2nvxh/Instagram+2.5.0.ipa) which is identical to the one available in App Time Machine in Whited00r 6.
2. Download Instagram to your iDevice
3. Go to Cydia
5. Install iFile
6. Than go to iFile
7. Go to the Instagram.app
8. Go to info.plist
9. Change the version to 4.0.1 in both these strings

   <key>CFBundleShortVersionString</key>
   <string>4.0.1</string>
     
   <key>CFBundleVersion</key>
   <string>4.0.1</string>

10. Open Instagram
11. USE ONLY THE LOG-IN button (because than it will read the server only, if you register than it will also write on the server..)
12. U have now your Instagram back..

See ya.
Young Maine

I followed those steps on my testing device: iPhone 3G Factory Unlocked running stock iOS 3.1.3 jailbroken & as reported above by leejenshil it did not fix the "Your version of Instagram is out of date. Please upgrade your app in the App Store to sign up for Instagram." error.

Are you 100% sure that you have Instagram v2.5.0 installed on your iPhone 3G? You can check the installed version by using the free iTools (http://itools.hk/en_index.htm) Windows version. I don't know if the iTools Mac version has the same features.

What is the iOS version on your iPhone 3G?

I get the same error as illustrated in the post #1 of this merged thread: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1 (http://www.whited00r.com/forum/index.php/topic,6992.0.html)

(http://vaiofseries.com/whited00r/Error_Your_version_of_Instagram_is_out_of_date_iPhone_3G_PierreP.png)


The simplified steps I did using the built-in plist editor in iTools by simply double-clicking on any .plist files:

1- Download & install Instagram using App Time Machine in Whited00r 6 or use this link: Instagram+2.5.0.ipa (direct link) (http://www.mediafire.com/download/8qmhsh0zoo2nvxh/Instagram+2.5.0.ipa) and use iTools or iFunbox to install it to your iPhone.

2- With the iPhone connected to the computer, use iTools to navigate to > iPhone > File System > Apps(User) > Instagram > Instagram.app > Info.plist > and double-click it to edit it.

(http://vaiofseries.com/whited00r/Instagram_v2_5_0_iTools_info_plist_mod_PierreP.PNG)


3- Replace the two <string>2.5.0</string> with <string>4.0.1</string>. You can use the plist editor Search feature with 2.5.0 to find them. Edited strings now look like this:

   <key>CFBundleShortVersionString</key>
   <string>4.0.1</string>
     
   <key>CFBundleVersion</key>
   <string>4.0.1</string>

Don't forget to hit Save top left & close the editor.

4- Turned off & back on the iPhone 3G and tried to Login to my Instagram account & failed with the same "...Instagram is out of date" error..  :(
Title: .
Post by: itsYoungMaine on July 24, 2013, 10:11:32 PM
.
Title: Re: Instagram v2.5.0 fix - info.plist Mod - Not Working
Post by: PierreP on July 24, 2013, 11:31:46 PM
...i have 2.5.0... if you make a picture now, than you will get that again.. You can only watch pictures sadly enough..

So your trick of faking that Instagram v2.5.0 is a newer v4.0.1 does not work really probably because the Instagram servers are using newer code that only newer devices & newer Instagram app version can understand, just like WhatsApp did: [50% Solved] WhatsApp WD6 Problem - Partially Working Update! (http://www.whited00r.com/forum/index.php/topic,7068.0.html)

"...You can only watch pictures" - You should have mentioned this in your original Instagram fix post suggestion because we have thousands of users reading our forum so it is important to be exact & to include details when proposing a fix.

Thank you anyway for trying.  ;)
Title: Instagallery partially working
Post by: m1namoto on August 01, 2013, 01:15:47 AM
ahah...new unworked solution?  :D
"...You can only watch pictures"

I can only watch/like/post comments in instagallery app  :)




PierreP Moderator note: Edited the post's title to add relevant keywords as described in Whited00r 6: Tips to Quickly Solve your Problems/Bugs & Get Answers FAST! (http://www.whited00r.com/forum/index.php?topic=6934.0)
Title: Re: Instagallery partially working?
Post by: PierreP on August 01, 2013, 06:51:27 PM
...I can only watch/like/post comments in instagallery app  :)

Could you give more details please?  :o

1- Which Instagallery version exactly? Because currently in iTunes Instagallery v1.4.9 (https://itunes.apple.com/us/app/instagallery-browse-instagram/id422065992?mt=8) is a paid app & "Requires iOS 4.3 or later".  Update:  Instagallery 1.5 in iTunes (https://itunes.apple.com/us/app/instagallery-browse-instagram/id422065992?mt=8) "Requires iOS 5.0 or later".  :-\

2- On which device running which version of iOS or is it Whited00r?

3- Could you provide a link to where one can download it?

4- You cannot upload photos to your Instagram account nor delete them, right?
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: mackiw on August 20, 2013, 02:11:09 PM
LOL! I also have INSTAGallery before but I deleted it though... But its nice too... you can view, like, comment photos... you can download it at pandaaap INSTAGallery 1.3.3 (http://download.pandaapp.com/ios-iphone-ipad-app/instagallery---browse-instagram-photos-1.3.3-id17610.html#.Ug20ZNJJOAg)
Title: Re: Instagallery App Broken Link
Post by: PierreP on August 21, 2013, 02:47:10 AM
...I also have INSTAGallery before but I deleted it though... But its nice too... you can view, like, comment photos... you can download it at pandaaap INSTAGallery 1.3.3

Thank you for the effort but all the download links in that page are broken.  :-\  You should always test a link before sharing it in the forum so other users do not waste their time. Could you post a direct working link?

Also that Instagallery v1.3.3 page says "Requirements : iOS 4.1 or later" so that would not work in Whited00r which is based on the faster iOS 3.1.3 but optimized, customized & with added features.

The oldest version of Instagallery is v1.0 and it requires iOS 4.1+ and the current Instagallery 1.5 in iTunes (https://itunes.apple.com/us/app/instagallery-browse-instagram/id422065992?mt=8) "Requires iOS 5.0 or later".  :-\
Title: Re: Instagallery App Broken Link
Post by: mackiw on August 21, 2013, 04:29:53 AM
Thank you for the effort but all the download links in that page are broken.  :-\  You should always test a link before sharing it in the forum so other users do not waste their time. Could you post a direct working link?

Also that Instagallery v1.3.3 page says "Requirements : iOS 4.1 or later" so that would not work in Whited00r which is based on the faster iOS 3.1.3 but optimized, customized & with added features.

The oldest version of Instagallery is v1.0 and it requires iOS 4.1+ and the current Instagallery 1.5 in iTunes (https://itunes.apple.com/us/app/instagallery-browse-instagram/id422065992?mt=8) "Requires iOS 5.0 or later".  :-\

LOL! REALLY? Just click the "FAST DOWNLOAD" button and thats it!

Only for iPhone 3G, iPod 2g running iOS 4.2.1
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: mackiw on August 21, 2013, 04:38:17 AM
(http://Capture.PNG)

Title: Re: Instagallery App Broken Link
Post by: PierreP on August 21, 2013, 05:54:48 AM
LOL! REALLY? Just click the "FAST DOWNLOAD" button and thats it!

Only for iPhone 3G, iPod 2g running iOS 4.2.1

Ah... those 3 are broken: filedude.com fileape.com mediafire.com

I thought Fast Download was to trick you to pay something like on so many other sites.  :)
Title: Instagram Working Maybe?
Post by: david1990 on September 21, 2013, 05:14:02 PM
Hi guys ! :D I was able to put Instagram working on iphone 3g with some files replacements, but i'll try it again and then who knows? Ifd it works i upload the ipa, but i don't think it will ... the API is the problem but, it worked somehow, guess i just had lucky ... Nice though

Consecutive post merged by moderator:

 >:(I really think that there will be no way to bypass this error, the erroris in the api, maybe it's a new one, if its true, we're screwed . I gues i just had lucky and it logged in ... but if it logged in taht means that the problem here is not the api .. what a mess
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: mackiw on September 24, 2013, 03:26:37 AM
Apple will now let you download the older versions of their apps. But then again, I cannot log in to Instagram!!!
Title: Re: Instagram Working Maybe?
Post by: mackiw on September 24, 2013, 03:28:30 AM
Hi guys ! :D I was able to put Instagram working on iphone 3g with some files replacements, but i'll try it again and then who knows? Ifd it works i upload the ipa, but i don't think it will ... the API is the problem but, it worked somehow, guess i just had lucky ... Nice though

Consecutive post merged by moderator:

 >:(I really think that there will be no way to bypass this error, the erroris in the api, maybe it's a new one, if its true, we're screwed . I gues i just had lucky and it logged in ... but if it logged in taht means that the problem here is not the api .. what a mess

Really? You were able to login to instagram?
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: david1990 on October 07, 2013, 12:20:58 AM

Really? You were able to login to instagram?
Yes but this is slow as f**k
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: n0s-speed on October 07, 2013, 06:11:09 AM

Yes but this is slow as f**k

A slow Instagram but works well better than a completely not working Instagram. ;)
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: xxRockOnxx on October 20, 2013, 11:23:56 AM
Hey guys, any update?

It's true that apple let you download older versions now.

Now i have instagram, the problem is still there... I can't login.

Did the public protest worked? Or any working solution?
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: n0s-speed on October 20, 2013, 12:32:18 PM
Sadly, not yet :(
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: xxRockOnxx on October 20, 2013, 01:02:50 PM
Is there we can do to this? Other than keep on hoping? xD

Hey what if you guys just an app? Similar to this? But same server? Just ask for a permission of the owner.. Would that work?

Coz idk what the ---- is API
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: n0s-speed on October 20, 2013, 02:43:56 PM

Hey what if you guys just an app? Similar to this? But same server? Just ask for a permission of the owner.. Would that work?

I think if it won't be Difficult it will be Impossible.
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: Bruan on October 20, 2013, 05:42:13 PM
Is there we can do to this? Other than keep on hoping? xD

Hey what if you guys just an app? Similar to this? But same server? Just ask for a permission of the owner.. Would that work?

Coz idk what the ---- is API

Nothing we can do sadly :( Closed source, they can't update the app anyway (and wouldn't even if they could because it takes really way too much effort to support old devices and new ones. Why force yourself to stay outdated with security holes, right? ;) ).

As for making another app for it, no. That would take time and effort we simply don't have :(
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: david1990 on October 20, 2013, 05:45:15 PM

Nothing we can do sadly :( Closed source, they can't update the app anyway (and wouldn't even if they could because it takes really way too much effort to support old devices and new ones. Why force yourself to stay outdated with security holes, right? ;) ).

As for making another app for it, no. That would take time and effort we simply don't have :(
just buy a newer iPhone
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: Bruan on October 20, 2013, 05:49:16 PM
just buy a newer iPhone

Exactly ;) You don't expect older computers to still have support for the latest games, it's just not logical. Old games that use online servers no longer work with old versions of those games, you buy computers that can run the latest games.   Technology moves on and advances.  We don't still use crank start cars for a reason as well ;)


It is sad that the servers finally gave up and can't support us anymore, but really, there is nothing to do :(
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: fantoche on November 09, 2013, 10:31:40 PM
just bought my first iphone (3G of course, i'm very broke here and can't buy a newer model) and im very bored to not have instagram. already installed few music apps (i'm a music producer), fl studio, teknobox, rebirth and for me that is enough.but as i'm into music and extreme sports, losing instagram i feel i'm losing the glamour of my life(LOL, a bit like that). already uploaded tons of pics when i was in the android. cant stop now just I finally changed to iOS

I don't know if you guys had this ideia before but i think its quite doable. lets think in a personal third party instagram uploader.
 my ideia consists in follow steps bellow. i have basic skills in a few programming languages/ macro applications for ms windows and i'm very tempted to implement and try that
Human steps (done by me)
1- take a picture with the iphone 3G camera
2- send it by email
Steps that my personal software will do
3- another email account grab it in my home PC
4- (optional, maybe hard to implement) apply filters via pre-defined commands that I will text in the body of email (no preview of course)
5- upload the picture to instagram via any android virtual machine (eg bluestacks, virtualbox)

i think anyone with a few knowledge in programming can implement that as well
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: Bruan on November 09, 2013, 10:48:07 PM
Welcome to the forums :)

A third party server would be nice, although I don't think there is any way we could provide one to the public for a number of reasons. Authentication would be a big one, how do we know it's just whited00r users, as well as keep it with instagram too to make them happy ;) Does the API still work with 3.1.3? I know a lot of API for major services has been updated and requires at least iOS 4 (no, we cannot port it to work with 3.1.3... It's official for a reason ;) ) because of the type of coding they use. Not saying that's how instagram does it, but that's something to keep in mind.  Also the authentication API, is it still 3.1.3 compatible, or not? Maybe that's why the apps all stopped working anyway because they made it require a newer authentication method, which may be possible to use in 3.1.3, but then again it may not.

Just being the voice of doom :(
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: fantoche on November 14, 2013, 11:03:20 PM
no no. i think you didn't understand me. Sorry, english is not my main language.

my intentions is a private and particular Windows application, no plans for a public server!

And I think this app is almost working!

I just downloaded and tested Gramblr for Windows and it works. Gramblr will be the final link in this workaround.

Also, I just downloaded this app: Mail Attachment Downloader http://download.cnet.com/Mail-Attachment-Downloader/3000-2369_4-10971605.html (http://download.cnet.com/Mail-Attachment-Downloader/3000-2369_4-10971605.html)
It download any attachment from your email account. It have smart filters like, check every new message in a period of time, and just download certain extensions only from a certain email adress. That will help a lot my job.

I already have tons of macro applications (i play a few online games, you know sometimes you need to survive!). But  I will use Macrogamer, it is very simple, and can do what I want. Automation of mouse movement and it can send keystrokes, that's enough for the task.

So the whole chain/flowchart is (assuming my home PC is already powered on and connected to the internet)

1- I take a picture with the iphone camera
2- Send from my iPhone the picture to the email [email protected]
3- Mail attachment downloader will download the pic in my home PC
4- My personal software will check if have new pics downloaded by Mail Attachement Downloader
5- If Yes it will launch Macrogamer's Macro for upload a picure in Gramblr
This macro consists basicaly by: 1- (send keystrokes)enter my Instagram username/password, 2 (recorded mouse movements) find the downloaded picture by Mail Attachement Downloader, 3 - (recorded mouse movements) Upload the pic to Instagram 4- (recorded mouse movements) Reset Gramblr to show the first screen making it ready for the next pic

I should make a few code only to caption the pics

not a elegant way to have Instagram in your iPhone 3G, but I think it could work! I will try this very soon.

Oh, and thanks a lot for whited00r. This forum is very cool!
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: Bruan on November 14, 2013, 11:41:13 PM
Very ingenious indeed, I was going to suggest a custom little server over the wifi network, but that wouldn't work away from home without more tweaking ;) 

I understand what you are meaning now, that is, as I said, very smart :)
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: adnanabidk on November 20, 2013, 11:04:02 PM
is it still working ? plz someone reply
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: Bruan on November 21, 2013, 06:33:15 PM
is it still working ? plz someone reply

Instagram is still broken, aside from any workaround posted here, either by using other services and such.  The official app is still kaput, and will likely stay like that :(
Title: Re: Your version of Instagram is out of date Error Not Working iOS 3.1.3, 4.1, 4.2.1
Post by: Superhitech on June 19, 2014, 07:49:38 PM
Try this, I am testing it out today
http://www.whited00r.com/forum/index.php/topic,11658.0.html