Whited00r Forum

Whited00r News => Firmware news and updates => Topic started by: mattewre on January 02, 2013, 11:45:12 AM

Title: Broken WhatsApp Protest Campaign
Post by: mattewre on January 02, 2013, 11:45:12 AM
Help us save Whatsapp for iPhone 3G. Spam the support service of Whatsapp. We are BIG, they can't ignore us.

Every Whited00r user should spend 1 minute for this, please do it for the community. Thank you.

http://www.apptimemachine.com/compatibility.php

The up-to-date thread in the Whited00r Forum:  [50% Solved] WhatsApp WD6 Problem - Partially Working Update! (http://www.whited00r.com/forum/index.php/topic,7068.0.html)
Title: Re: WhatsApp support
Post by: Giel on January 02, 2013, 12:11:55 PM
I just sent an email to them, with indeed the question to extend the support of older ios versions and other older devices.

I hope it makes a point..
Title: WhatsApp Support Reply
Post by: alphonse on January 09, 2013, 11:19:45 AM
Got the following answer - guess it is game over:
Quote
Hi,

Thanks for your message. Apple no longer supports the iPhone 3G, nor does WhatsApp.

In order for WhatsApp to provide a more secure and reliable service for all of our users, we simply cannot continue supporting older versions of the app. If you have WhatsApp Messenger version 2.8.4 for iPhone, you should be able to continue using WhatsApp with the same phone number. Unfortunately, Apple does not provide any way for us to distribute previous versions of the app, so you will need to have had previously downloaded version 2.8.4.

WhatsApp is an internet-driven service. It requires all of the devices that connect to it to be able to use the same protocol (similar to "speaking the same language"). As our protocol evolves to add new features and improve security and performance, it becomes imperative to enforce all of our devices to use the newer protocol. Otherwise, our system becomes vulnerable to attackers and spammers. If we allow old devices into the system, we allow the few users with old devices to jeopardize the experience for the rest of our users. Eventually, the protocol will evolve to a point where old devices will simply not understand the new protocol entirely.

You can read our latest blog post to learn more about why WhatsApp Messenger now requires iOS 4.3 or later: http://blog.whatsapp.com/index.php/2012/12/iphone3g/

It's not as simple as "Your device is too old", but the bottom line is: "Your device is too old."

-ken