Whited00r Forum

Development - iOS Custom Firmware => Redd00r Project - Works on iOS 4.1 or iOS 4.2.1 Firmwares! => Topic started by: momoclax on March 06, 2013, 02:48:35 AM

Title: Can't install Redd00r
Post by: momoclax on March 06, 2013, 02:48:35 AM
PierreP moderator note 2013-07-31:
Redd00r is really buggy and old and does NOT work anymore. We recommend waiting for an update that will be announced after the next Whited00r update. Sorry, we cannot give a release date yet so please do not ask.

Meanwhile, you can try bcooperizcool's Archetype -- Custom firmware package for every iOS (http://www.whited00r.com/forum/index.php/topic,6849.0.html)

*****

Original post:

I just upgrade my Iphone 3G from Whited00r 6 to Stock IOS 4.2.1 and planning to install Redd00r for tweak it.
I was following instruction to install Redd00r, but I have problem when I want to install mobile substract.
Mobile substract (Ver. 1) on my cydia not compatible with IOS 4.2.1. what version of mobile substract that compatible with IOS 4.2.1 and Redd00r ? and where can I get it ?

thank you
Title: Archetype - Redd00r alternative
Post by: Bruan on March 06, 2013, 02:53:55 AM
I just upgrade my Iphone 3G from Whited00r 6 to Stock IOS 4.2.1 and planning to install Redd00r for tweak it.
I was following instruction to install Redd00r, but I have problem when I want to install mobile substract.
Mobile substract (Ver. 1) on my cydia not compatible with IOS 4.2.1. what version of mobile substract that compatible with IOS 4.2.1 and Redd00r ? and where can I get it ?

thank you
I would actually advise not using redd00r, until the next update. (I know that sounds bad, but I wouldn't, having made some of the stuff it relies on, and having updated it a lot since then).


I personally would recommend Archetype - a custom firmware package for every iOS version and device (http://www.whited00r.com/forum/index.php/topic,6849.0.html), not just because I made it, but because it is more stable and has more features (relatively) as well.  (Also in regular development, so if you find a bug, post in the thread and an update will be out shortly if I can find a fix for it ;)  ).


If you choose to still use redd00r, I will write up the answer for getting mobile substrate then ;)
Title: Re: Can't install Redd00r
Post by: momoclax on March 06, 2013, 03:03:35 AM
I will try your recomendation :) thank you for fast reply


Edit:

it's for 3.1.3 only? actually I need 4.2.1 for wider apps compability :)
Title: Re: Can't install Redd00r
Post by: Bruan on March 06, 2013, 03:15:12 AM
I will try your recomendation :) thank you for fast reply


Edit:

it's for 3.1.3 only? actually I need 4.2.1 for wider apps compability :)
It is for every firmware :)  It dynamically changes what it does on each firmware, so it can be installed on anything (I have it running on my iPod touch 4 on iOS 6.1 at the moment, at the same time as my iPhone 2g).



Title: Re: Can't install Redd00r
Post by: momoclax on March 06, 2013, 03:40:57 AM
I will try your recomendation :) thank you for fast reply


Edit:

it's for 3.1.3 only? actually I need 4.2.1 for wider apps compability :)
It is for every firmware :)  It dynamically changes what it does on each firmware, so it can be installed on anything (I have it running on my iPod touch 4 on iOS 6.1 at the moment, at the same time as my iPhone 2g).

Oowh, thank you.. I will try it
Title: Re: Can't installMobileSubstrate
Post by: redz11029 on June 09, 2013, 03:54:59 AM
Can you still put up the instructions for getting mobile substrate? i cant get archetype without it.
Title: Re: Can't install MobileSubstrate
Post by: Bruan on June 09, 2013, 05:38:15 AM
Can you still put up the instructions for getting mobile substrate? i cant get archetype without it.

Welcome to the forums :)

What device/firmware are you using?  Archetype is completely different than redd00r as well BTW, and the two are not compatible with each other.
Title: Re: Can't install Redd00r
Post by: akirro on July 04, 2013, 09:56:26 AM
Hi i have an iphone 3g 4.2.1 jailbreaked with redsn0w and i need mobile substrate to install archetype, (but i can't as descripted above because i need firmware >4.3) can you give me the solution please ?
Title: Re: Can't install Redd00r
Post by: Bruan on July 04, 2013, 02:44:39 PM
Hi i have an iphone 3g 4.2.1 jailbreaked with redsn0w and i need mobile substrate to install archetype, (but i can't as descripted above because i need firmware >4.3) can you give me the solution please ?

Did you happen to add in the repod00r repo, or the redd00r repo?  I think those mess up the mobile substrate official repo thing :(

Aside from that, I don't know why it doesn't work with 4.x :(
Title: Re: Can't install Redd00r
Post by: akirro on July 05, 2013, 05:28:22 PM
Yes it was this, thanks a lot
Title: Re: Can't install Redd00r
Post by: Bruan on July 05, 2013, 05:32:27 PM
Yes it was this, thanks a lot

You got it working by removing the repo?
Title: cant install redd00r
Post by: hyst10 on July 06, 2013, 02:36:44 PM
every time i try to install redd00r cydia crashes and it wont open :-[ :-[ :-[ :-[ :-[
Title: Re: cant install redd00r
Post by: Bruan on July 06, 2013, 03:41:38 PM
Redd00r is long outdated and unstable as well as unsupported at this time.   Someone is working on it, but I haven't heard anything from them for a while :/
Title: Re: cant install redd00r
Post by: hyst10 on July 06, 2013, 05:56:20 PM
Do you have another firmware you can recommend to me?
Title: Re: cant install redd00r
Post by: Bruan on July 06, 2013, 06:04:18 PM
Do you have another firmware you can recommend to me?

You could try Archetype (http://www.whited00r.com/forum/index.php/topic,6849.0.html), although if it crashes during install, just open cydia up right away and let it finish the install :)

Much more features than redd00r, and more stable.  (also up to date ;) ).
Title: Re: cant install redd00r
Post by: zarraza on July 09, 2013, 05:53:53 PM
N00b here with a Q.
i researched redd00r for quite a while but never could get it to work, had a helluva time getting ANY jailbreak from redsn0w to work with my MC iPod touch 2G so after many trials I had to use greenpois0n.
my questions is probably covered SOMEWHERE in this forum but I've done a bit of searching and came up empty.

what I'm wondering now is - is the ch40s utilities something in cydia? is it a standalone app?

I'm fascinated witht he new ARCHETYPE - is that something that is all wrapped up in an IPSW file or is it downloadable after jailbreak?

I've scoured the internet for months for a "jailbreak guide for dummies" but haven't seen anything that was not only a step by step but also a tutorial as to WHY I am doing what I am doing - for all you smart guys out there, do you have any such "guide for dummies" that you could share?
seems all the youtube videos out there for installing redd00r assume your device is already jailbroken, you don't know how long it took me to figure THAT out!!!!

FTR, I got my MC jailbroken with greenpois0n and a downloaded IPSW for 4.2.1 but not sure what to do with it now - my original goal was the features that are in redd00r but since that project doesn't seem to be getting any love anymore, I guess I could switch to ARCHETYPE, but this n00b is just a little unsure where to start with a new project, and if it even works with the MC touch devices!!!!

thanks in advance all, please forgive my ignorance on the subject, and keep up the good work.


Title: Re: cant install redd00r
Post by: Bruan on July 09, 2013, 06:10:11 PM
Welcome to the forums :)

I am pretty sure that greensn0w is the correct way to jailbreak the MC model devices, as that is what I did for my brother even to install an old archetype version on it.

So, I don't know of any step by step guide as to why you need to do each step, but I do know of guides that tell you what to do, but I guess you found those ;)

As for Ch40s-Utilities, it is a backend framework for developers that lets them code stuff easily, and in the case of redd00r and archetype, execute shell code, use ota updates and a bunch of other things (although the executing code is not going to be used as much as I learned obj-c, but new developers could learn it with it).   The goal of it is to provide one tool for the developers needs instead of making a bunch of hackey launchers to execute code and such.  Dynamic and things I guess ;)

Archetype is something you download after you are jailbroken, and it is compatible with every firmware and device, although seeing it is beta, there are some workarounds on some devices and firmwares to get it working ;)

That being said, I think the install on the iPod touch 2G is fine, although the multitasking doesn't work because I forgot to put in a couple lines of code to make it work properly (it still shows up, but will crash you when you try to switch apps).

To install Archetype, you have to be jailbroken, which you are, so you just go to Cydia and add in the repo for it and install it (it will take ages to install because of all the code it runs, but the end result is amazing :) ).   Make sure you do not have the repod00r repo or the redd00r repo added in Cydia as that will stop you being able to install mobile substrate!.
Title: Re: Can't install Redd00r
Post by: applepie on July 20, 2013, 11:42:10 PM
I know the problem..I remember I put an old version of mobile substrate on my repo due to a weird incompatibility with the current version and the silly "Redd00r Base Firmware iPhone 3g". Anyhow if you still wish to use it....you need to remove the repo..install MobileSubstrate FIRST then add the repo and install.

Also opposite goes for Ch40s-Utilities. Unfortuantly redd00r hasn't been updated to use the latest versions of ch40s utilities. So you'll have to use the version on the redd00r repo (~1 year old). Sadly, this means you won't be able to use any newer tweaks that use the newer ch40s utilities....
Title: Re: Can't install Redd00r
Post by: superbeak on July 21, 2013, 02:49:43 AM
Hopefully the redd00r update wont even use ch40s. Given the power of bundles and the like. :D
Title: Re: Can't install Redd00r
Post by: AnimateDread on July 21, 2013, 05:21:15 AM
Hopefully the redd00r update wont even use ch40s. Given the power of bundles and the like. :D
That should be there since the start (as I saw, applepie is pretty good in obj c)
Title: Re: Can't install Redd00r
Post by: applepie on August 01, 2013, 06:20:00 AM
That should be there since the start (as I saw, applepie is pretty good in obj c)
I could make the whole thing in objc...but when I was working on it we already had scripts made from older (unrealeased) versions of a configurator gui..so it was easier to just use those scripts and have the app just run those than remaking it in objc. in addition, ch40s utils had some useful things like ota updates and a function to launch an app upon boot up (which was used to launch the config app after restarting after installing the redd00r package) that I would have to code myself in objc if I didn't use ch40s utilities.
Title: Re: Can't install Redd00r
Post by: Bruan on August 01, 2013, 03:53:31 PM
I could make the whole thing in objc...but when I was working on it we already had scripts made from older (unrealeased) versions of a configurator gui..so it was easier to just use those scripts and have the app just run those than remaking it in objc. in addition, ch40s utils had some useful things like ota updates and a function to launch an app upon boot up (which was used to launch the config app after restarting after installing the redd00r package) that I would have to code myself in objc if I didn't use ch40s utilities.

The configurator was still better done in shell because of the massive amounts of file system moving to be done :( 

Using obj-c to execute code is a smart thing to do though ;)