Author Topic: WD7.1 iPhone 3G sound speaker does not work for music or calls/notifications  (Read 1418 times)

Offline Sir Roven

  • Senior Member
  • ***
  • Posts: 56
  • Country: pt
  • Dev Android | Iphone 3G Intro
    • View Profile
  • Device: iPhone 3G
  • My Computer: Windows
hi whitedoor users i have problem with my iphone 3G WD7.1 the problem is sound speaker does not work for music and calls and notifications but work when i put my phone charge by usb in pc or simple charge... strange anyone can help i loose much calls :(

Edit by Bruan to provide more keywords in the title :)
« Last Edit: July 26, 2014, 06:28:44 AM by Bruan »
Developer Android on XDA MediaTek Devices
Introducing to a world to old IDevices
_--_--_--_--_--_--_--_--_--_--_--_--_--_--_--_--_

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
When you restored to whited00r, did you set up as a new device in iTunes, or restore from a backup?

Have you installed any extra tweaks from Cydia, or done any file system mods? (For example, the type meant to try and boost the volume of that speaker.)

Does the device have any hardware damage? I am pretty sure the noise the phone makes when plugging into the PC comes from a different internal speaker, because even the first gen iPod touch which had no speaker did that. (if it is the iPhone and not the PC just making the noise it always makes)

Offline Sir Roven

  • Senior Member
  • ***
  • Posts: 56
  • Country: pt
  • Dev Android | Iphone 3G Intro
    • View Profile
  • Device: iPhone 3G
  • My Computer: Windows
Yes i set new device in itunes yes i have cyntact tweak and one mine for language PT update only plist file changes.

No iphone work well but someday agos dont work sound in speaker and i loose my notifications and calls, iphone

eg if I connect the iPhone to load the plug into the outlet that is without the PC sound is already working for whatever but if I remove already not working: S
Developer Android on XDA MediaTek Devices
Introducing to a world to old IDevices
_--_--_--_--_--_--_--_--_--_--_--_--_--_--_--_--_

Offline Bruan

  • Feature Developer
  • Administrator
  • SuperHero Member
  • *****
  • Posts: 13082
  • Country: 00
  • Methuselah
    • View Profile
    • Bruan_WD Twitter
  • Device: iPhone 3G
  • My Computer: Linux
Does it work in safemode?  You can enter safemode by running the following command in terminal:
Code: [Select]
killall -SEGV SpringBoard

Also, just checking, you do have the volume up for the ringer right?  (not the media...  Also, pretty sure having headphones in is a different volume than not, so set it when headphones are not in)

Does it vibrate for the notifications?  Is the silent switch on on the side of the device?  I know my iPhone 3G cannot actually turn silent mode on because the switch is wonky, perhaps yours is the other way around now and you cannot turn it off?