Support - Whited00r Custom iOS for iPhone 2G, 3G & iPod Touch 1G & 2G > Troubleshooting - iPhone & iPod Touch 1G/2G/3G, Unlock & Jailbreak Problems & Issues

Whited00r 6 - GPS problem iPhone 3G Baseband 05.13.04, 05.15.04 & 06.15.00

<< < (2/49) > >>

PierreP:
How about a fresh clean install again of WD 6?

After you backed up your device properly do a fresh clean Whited00r 6 install because as you can read in the whited00r Tutorial - Installation:


--- Quote ---After installation (could take up to 15 minutes, reboot the device twice) iTunes will ask you if you want to restore from a backup. Please choose “Set up a new iPhone/iPod” to

improve speed and avoid strange problems. Clean installation is better and the the only way to get our support!
--- End quote ---

Gorkij:
I tried to resolve whether this was due to whited00r or redsn0w. I use my external gps since my shipped SIM is no longer active but i need it to activate the phone in iTunes.
So I first restored to 4.2.1 stock via iTunes. Location service works with external GPS.
Jailbreaked and updated baseband to 06.15 with redsn0w 0.9.6.
Downgraded baseband to 05.13.04 with redsn0w 0.9.14b2 - location service works with external gps.
So far so good.

Install WD6 unlocked version. It connects nicely to the bluetooth gps-dongle. Location service no longer works in maps.
Hard reboot. Still no location service.
Updating cydia packages and ultrasnow, hard reboot. Still no location service.
I run the com.apple.locationd.plist-scripts that was posted above. Still no location service.
I clean up the daemons via Terminal->setup. Still no location service.

Doesn't seem like this problem is attached to either redsn0w or the baseband since location service was functioning before I installed whited00r.
Could the push function anything to do with this?

Update: I tried switching to the SIM card that I normally use with my 4S. Works perfectly, sending and reciving calls. Data over 3G also without problem. Still no location with external GPS. If I turn both external GPS and WiFi off and go into the maps app I get a huge approximate location but no fix.
BUT the phone gets quite hot, just like it would if using the gps chip. This has got to be some software problem in whited00r.

momircar11:
F0recast says that I have bootloader 6.4  :o And running terminal script didn't help :( Here's the screenshot:

Bruan:
try removing /etc/hosts, just as an idea (rename it to something else, dont delete it)

momircar11:
Nope. Still the same :( Maybe I need to reboot my phone? I just resprung it..

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version